Project

General

Profile

Actions

Bug #3648

closed

Create Report format converter

Added by debi staggs about 14 years ago. Updated about 14 years ago.

Status:
Resolved
Priority:
Normal
Category:
reporting
Target version:
Start date:
11/12/2008
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
3648

Description

Create a report format converter that generates the .pdf and/or .html files from the Report Instance (RIO) XML.


Related issues

Has duplicate Kepler - Bug #3636: Support multiple Report formatsResolvedben leinfelder11/12/2008

Actions
Actions #1

Updated by ben leinfelder about 14 years ago

Some key considerations:
Where are images housed and referenced in the HTML case
-Styling (CSS) for HTML needs to be specified (beginning in the ROML and cascading down: ROML
>RIO->HTML)
-PDF is "easier" in the sense that the images can be looked up from provenance, embedded in the document and forgotten about (not essential to export them)

Actions #2

Updated by ben leinfelder about 14 years ago

This is essentially done. Using FOP for most of it; a little vanilla xsl to get the html.
Consolidating this into #3636

  • This bug has been marked as a duplicate of bug 3636 ***
Actions #3

Updated by Redmine Admin almost 10 years ago

Original Bugzilla ID was 3648

Actions

Also available in: Atom PDF