Project

General

Profile

Bug #3723

all actors appear in the same upper-left position when dragged onto canvas

Added by Derik Barseghian almost 11 years ago. Updated almost 11 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
interface
Target version:
Start date:
01/05/2009
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
3723

Description

All the actors appear in the same upper-left position no matter where you drag them onto the canvas. Like bug #3722, this may be due to a ptII change and not a kepler change, as Crawl notes it also occurs in an old revision of kepler (before recent repository change accommodating the new build system) with a new revision of ptII.

History

#1 Updated by Christopher Brooks almost 11 years ago

Fixed by updating vergil/basic/EditorDropTarget.java
I'm not sure what the original cause was, but it looks like some refactoring
meant that EditorDropTarget needed to append the location to the MoML
change request. Part of the issue is that Kepler has a
_alternateGetMomlAction that is not used in Ptolemy, which is why this bug
did not appear in Ptolemy.

#2 Updated by Redmine Admin over 6 years ago

Original Bugzilla ID was 3723

Also available in: Atom PDF