Project

General

Profile

Bug #3782

Kepler-trunk fails to properly read in kar files the first time after they are built.

Added by David Welker about 10 years ago. Updated over 9 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
core
Target version:
Start date:
01/27/2009
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
3782

Description

Kepler from the trunk (hereinafter "kepler-trunk") fails to read kar files the first time immediately after they are build.

The problem can be reproduced by the following sequence of commands and associated relevant ouput:

First Set of Commands: ======================
ant change-to -Dsuite=vanilla-trunk
ant update
ant clean-cache
ant run

Relevant Output: ================
run:
[run] Building Kars...
...
[run] KAR Library directories: []
...

At this point, you cannot drag actors to the canvas from the library pane. Shut down Kepler and run the following command:

Second Set of Commands: =======================
ant run

Relevant Output: ================
run:
[run] Building Kars...
...
[run] KAR Library directories: [/Users/davidwelker/kepler.modules/common/kar/actors, /Users/davidwelker/kepler.modules/common/kar/directors]
...

Now the actors do exist in the actor pane and can be dragged to the canvas.

======
This problem does not exist for kepler-1.0. Since the build system is precisely the same for kepler-trunk and kepler-1.0, we can infer that the source of this problem is a change made recently in kepler-trunk. (This conclusion is reinforced by the fact that this problem did not used occur when running kepler-trunk.)

History

#1 Updated by David Welker almost 10 years ago

This bug has somehow been resolved. I tested it today and could not reproduce the error any longer.

#2 Updated by Chad Berkley over 9 years ago

no longer a problem.

#3 Updated by Redmine Admin almost 6 years ago

Original Bugzilla ID was 3782

Also available in: Atom PDF