Project

General

Profile

Bug #3803

Cannot open a workflow through the command prompt, open with, or send to menus

Added by Oliver Soong almost 11 years ago. Updated over 10 years ago.

Status:
New
Priority:
Low
Category:
interface
Target version:
Start date:
01/29/2009
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
3803

Description

XP Pro x64 SP2, Java 1.6.0_11, Kepler 1.0.0 from kepler-project.org

If I right click a workflow file and select Open With->Kepler, I get an error.

If I add a shortcut to Kepler to my SendTo menu, then right click the workflow file and use the Send To link, I get the same error.

If I call Kepler from the command prompt with the workflow as the only argument, I get the same error.

An image of the error is at the URL.

I think this feature is available under linux:
https://dev.kepler-project.org/developers/reference/executing-kepler-from-the-command-line

History

#1 Updated by Oliver Soong almost 11 years ago

Here's the stack trace:

java.lang.Exception: Failed to parse "-kepler C:\Program Files (x86)\Kepler-1.0.0\demos\getting-started\05-LinearRegression.xml"
at ptolemy.actor.gui.MoMLApplication.throwArgsException(MoMLApplication.java:584)
at ptolemy.actor.gui.MoMLApplication.<init>(MoMLApplication.java:245)
at ptolemy.vergil.VergilApplication.<init>(VergilApplication.java:98)
at ptolemy.vergil.VergilApplication$1.run(VergilApplication.java:141)
at java.awt.event.InvocationEvent.dispatch(Unknown Source)
at java.awt.EventQueue.dispatchEvent(Unknown Source)
at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.run(Unknown Source)
Caused by: java.lang.Exception: Failed to read configuration 'file:/C:/Program%20Files%20(x86)/Kepler-1.0.0/configs/ptolemy/configs/kepler/configuration.xml'
at ptolemy.vergil.VergilApplication._createDefaultConfiguration(VergilApplication.java:233)
at ptolemy.actor.gui.MoMLApplication._parseArgs(MoMLApplication.java:958)
at ptolemy.vergil.VergilApplication._parseArgs(VergilApplication.java:357)
at ptolemy.actor.gui.MoMLApplication.<init>(MoMLApplication.java:215)
... 10 more
Caused by: java.lang.Exception: Failed to call application initializer class "org.kepler.gui.KeplerInitializer". Perhaps the configuration file "file:/C:/Program%20Files%20(x86)/Kepler-1.0.0/configs/ptolemy/configs/kepler/configuration.xml" has a problem?
at ptolemy.actor.gui.MoMLApplication.readConfiguration(MoMLApplication.java:401)
at ptolemy.vergil.VergilApplication._createDefaultConfiguration(VergilApplication.java:231)
... 13 more
Caused by: java.sql.SQLException: The database is already in use by another process: org.hsqldb.NIOLockFile@f1b9222a[file =C:\Documents and Settings\osoong\.kepler\cache\cachedata\hsqldb.lck, exists=true, locked=false, valid=false, fl =null]: java.lang.Exception: The process cannot access the file because another process has locked a portion of the file : C:\Documents and Settings\osoong\.kepler\cache\cachedata\hsqldb.lck
at org.hsqldb.jdbc.jdbcUtil.sqlException(Unknown Source)
at org.hsqldb.jdbc.jdbcConnection.<init>(Unknown Source)
at org.hsqldb.jdbcDriver.getConnection(Unknown Source)
at org.hsqldb.jdbcDriver.connect(Unknown Source)
at java.sql.DriverManager.getConnection(Unknown Source)
at java.sql.DriverManager.getConnection(Unknown Source)
at org.ecoinformatics.util.DBConnectionFactory.getDBConnection(DBConnectionFactory.java:91)
at org.ecoinformatics.util.DBConnectionFactory.getDBConnection(DBConnectionFactory.java:73)
at org.kepler.gui.KeplerInitializer.initializeSystem(KeplerInitializer.java:143)
at org.kepler.gui.KeplerInitializer.<init>(KeplerInitializer.java:90)
at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
at sun.reflect.NativeConstructorAccessorImpl.newInstance(Unknown Source)
at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(Unknown Source)
at java.lang.reflect.Constructor.newInstance(Unknown Source)
at java.lang.Class.newInstance0(Unknown Source)
at java.lang.Class.newInstance(Unknown Source)
at ptolemy.actor.gui.MoMLApplication.readConfiguration(MoMLApplication.java:399)
... 14 more

#2 Updated by Oliver Soong almost 11 years ago

To clarify, this relates to the Open With and Send To menus in Windows Explorer.

I apparently had a Kepler session already open, and this behavior is due to the cache being locked. I get the expected behavior when Kepler is not already running. Kepler does not gracefully open additional windows or merge into the existing process if a session is already open.

Lowering priority and leaving open.

#3 Updated by ben leinfelder almost 11 years ago

Basically we need a way to bypass all the Kepler start up stuff and just open a workflow if Kepler is already running and you invoke it with the name of a workflow.

I'll also mention that on OS X, "open with" doesn't even work when Kepler is not already running...

#4 Updated by ben leinfelder over 10 years ago

not critical for 2.0 release. it's a nice feature to have, but not blocking the release.

#5 Updated by Redmine Admin over 6 years ago

Original Bugzilla ID was 3803

Also available in: Atom PDF