Project

General

Profile

Bug #3900

leaving fullscreen mode gives an NPE and closes window

Added by Derik Barseghian over 10 years ago. Updated over 10 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
interface
Target version:
Start date:
03/17/2009
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
3900

Description

On my mac, when I enter fullscreen mode, then hit the ESC key to leave fullscreen mode, I get an NPE and the window closes. I haven't tried another OS or had anyone replicate this yet.

Error:
[run] Exception in thread "AWT-EventQueue-0" java.lang.NullPointerException
[run] at ptolemy.vergil.basic.ExtendedGraphFrame.cancelFullScreen(ExtendedGraphFrame.java:115)
[run] at ptolemy.vergil.basic.ExtendedGraphFrame$FullScreenAction.actionPerformed(ExtendedGraphFrame.java:264)
[run] at javax.swing.SwingUtilities.notifyAction(SwingUtilities.java:1576)
[run] at javax.swing.JComponent.processKeyBinding(JComponent.java:2772)
[run] at javax.swing.JComponent.processKeyBindings(JComponent.java:2807)
[run] at javax.swing.JComponent.processKeyEvent(JComponent.java:2735)


Related issues

Has duplicate Kepler - Bug #2369: Scrollbars Disappear After Using Fullscreen Mode--Now crashesResolved02/24/2006

History

#1 Updated by Christopher Brooks over 10 years ago

The bug does not appear if I do
ant change-to -Dsuite=ptII
ant run # Open any model # View -> Full Screen # Hit the Escape key

The bug also does not appear in $PTII/bin/vergil in a regular
Ptolemy II devel tree (outside of Kepler)

I suspect that the recent refactoring of BasicGraphFrame to have
an init() method might have something to do with this, but this is
only a guess.

#2 Updated by Derik Barseghian over 10 years ago

This bug is pretty atrocious, I'm retargeting it to 2.0.0.

#3 Updated by Chad Berkley over 10 years ago

same as 2369

  • This bug has been marked as a duplicate of bug 2369 ***

#4 Updated by Redmine Admin over 6 years ago

Original Bugzilla ID was 3900

Also available in: Atom PDF