Project

General

Profile

Bug #2369

Scrollbars Disappear After Using Fullscreen Mode--Now crashes

Added by Matthew Brooke over 13 years ago. Updated almost 7 years ago.

Status:
Resolved
Priority:
Normal
Category:
interface
Target version:
Start date:
02/24/2006
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
2369

Description

1) open a workflow (can be a blank one)
2) go into full screen mode, either by selecting "Full Screen" on the "View"
menu, or by clicking the "Full Screen" button on the toolbar
3) use the "Esc" key to return to regular screen size
-> the scrollbars have now disappeared from the graph frame


Related issues

Is duplicate of Kepler - Bug #3900: leaving fullscreen mode gives an NPE and closes windowResolved03/17/2009

Blocked by Kepler - Bug #4784: Remove or fix and re-enable the fullscreen zoom buttonResolved02/09/2010

History

#1 Updated by Dan Higgins over 11 years ago

Problem not often encountered; delay fix

#2 Updated by Timothy McPhillips over 10 years ago

I am encountering this problem as well (on OSX). The scrollbars disappear when I go to full screen mode. They do not appear when I return to regular screen size. And clicking on the navigation pane does not restore the scrollbars, either.

#3 Updated by Timothy McPhillips about 10 years ago

This problem appears now to be worse (running kepler-trunk). Going to fullscreen mode and then hitting escape now causes a NullPointerException:

[run] Exception in thread "AWT-EventQueue-0" java.lang.NullPointerException
[run] at ptolemy.vergil.basic.ExtendedGraphFrame.cancelFullScreen(ExtendedGraphFrame.java:115)

#4 Updated by Derik Barseghian about 10 years ago

bug #3900 addresses the leaving full screen crash.

#5 Updated by Chad Berkley about 10 years ago

Try to figure this out and remove full screen mode if we can't get it fixed before 2.0

#6 Updated by Chad Berkley about 10 years ago

  • Bug 3900 has been marked as a duplicate of this bug. ***

#7 Updated by Daniel Crawl almost 10 years ago

I've disabled full screen mode since it crashes returning from full screen. (See my comments why this occurs in KeplerGraphFrame). If this can't be fixed, then the button should be removed.

#8 Updated by Christopher Brooks almost 7 years ago

There was a problem with scrollbars disappearing after fullscreen, but
View->Full Screen has been removed, so this bug is moot.

#9 Updated by Redmine Admin about 6 years ago

Original Bugzilla ID was 2369

Also available in: Atom PDF