Project

General

Profile

Bug #3925

ant run does not always work from paths with spaces

Added by Oliver Soong about 10 years ago. Updated over 9 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
general
Target version:
Start date:
03/31/2009
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
3925

Description

XP Pro x64 SP2, Java 1.6.0_11, Kepler 1.x dev build 17250

I checked out kepler to C:\Documents and Settings\soong\Desktop, but ant run doesn't work right. If I use the 8.3 filename, it almost works. If I create a junction at a path with no spaces, it works.

Path: C:\Documents and Settings\soong\Desktop\kepler\build-area
Fails due to whitespace quoting problem. Error says it can't find the main class "and" which it picks up from Documents and Settings.

Path: C:\Docume~1\soong\Desktop\kepler\build-area
Runs, but can't seem to access the network. I can't search KNB. There is no error, but it never returns. Existing datacans from loaded workflows are stuck at "Busy".

Path: C:\tmp\kepler\build-area
Seems to work for now.

History

#1 Updated by Madhusudan Gujral about 10 years ago

I notice similar problem while running java -jar kepler-trunk.jar on Windows machine. When installation folder is on desktop and directory name has a space in it.

#2 Updated by Oliver Soong over 9 years ago

I think this actually got fixed some revision in the past. At least, it works for me now.

#3 Updated by Redmine Admin about 6 years ago

Original Bugzilla ID was 3925

Also available in: Atom PDF