Project

General

Profile

Bug #3987

Obscured window when adding keyword from predefined list in OS X

Added by Jim Regetz almost 11 years ago. Updated over 10 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
morpho - general
Target version:
Start date:
04/15/2009
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
3987

Description

This arises during the Keywords step (step 3) of the New Data Package Wizard. Here are the steps to reproduce:

1. Click "Add". This opens a Define Keyword Set window.
2. Choose "These keywords are chosen from a predefined list", select either KNBRegistry or nbii, then click "Add". This opens a new window for keyword selection, e.g. Thesaurus Lookup.

The problem is that this second Lookup window opens "behind" the Define Keyword Set window. If you click on the Define Keyword Set window, the Lookup window pops forward, but as soon as you click on the Lookup window, it drops back again.

A workaround is to make sure your windows aren't overlapping :)

This problem only seems to happen during the New DP Wizard, not when adding keywords to existing DPs using the Documentation -> Keywords... option.

History

#1 Updated by Jing Tao almost 11 years ago

When morpho created this Lookup Dialog, it used UIController.getInstance().getCurrentActiveWindow() as the dialog's parent. However, this method usually get a opened package window or morpho main window, so the overlapping happened.

If we change the parent to WizardContainerFrame.getDialogParent(), it will uses the new package wizard frame as parent. That will make sure the dialog is will be in front of keyword window.

#2 Updated by Jim Regetz almost 11 years ago

Fixed. This also seems to have fixed a bug (unreported) on Ubuntu whereby clicking the Add button failed to do anything after selecting the nbii thesaurus.

#3 Updated by Jing Tao over 10 years ago

move to 1.7

#4 Updated by Redmine Admin almost 7 years ago

Original Bugzilla ID was 3987

Also available in: Atom PDF