Project

General

Profile

Bug #4174

Actor library not building correctly

Added by Aaron Aaron about 10 years ago. Updated about 10 years ago.

Status:
Resolved
Priority:
Immediate
Assignee:
Category:
actors
Target version:
Start date:
06/18/2009
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
4174

Description

Many of the actors are not appearing in the actor library when using the WRP suite. No visible errors are given...


Related issues

Blocked by Kepler - Bug #4047: Remove Component doesn't workResolved05/01/2009

Blocked by Kepler - Bug #4150: Save in Library brokenResolved06/12/2009

History

#1 Updated by Aaron Aaron about 10 years ago

It seems that the tagging module is overriding the ontologies. It just so happens that the kepler-component.owl file had one change in it.
xml:base="urn:lsid:localhost:onto:2:1 in the common module version
and
xml:base="urn:lsid:localhost:onto:54:1 in the tagging module version

I've reverted the change in the taggin module override and it seems to have solved the problem of the component library actors not showing up. However, I am going to leave this bug open until the other folks having the problem can verify that it has gone away.

#2 Updated by Aaron Aaron about 10 years ago

It has been verified that this fix worked and the Components are showing up again in the actor library.

#3 Updated by Derik Barseghian about 10 years ago

Not sure if the problem is still "actor library not building correctly" but I'm not seeing components in the tree in wrp, I think this re-broke roughly around the time the 'workflows not opening' bug was fixed...

#4 Updated by Derik Barseghian about 10 years ago

Narrowing this down a little: broken in r19366, but not in r19350.

#5 Updated by Chad Berkley about 10 years ago

This is now a problem in the kepler suite as well.

#6 Updated by Derik Barseghian about 10 years ago

Break occurs in r19364, changes to trunk/modules/core/src/org/kepler/kar/KARFile.java:
"subtle correction: if we find a KEH that handles the type, then we should call the open() method on that handler."

#7 Updated by Aaron Aaron about 10 years ago

yeah, rev 19364 of KarFile was the problem, I've rolled back that change and it is working again.

#8 Updated by Redmine Admin over 6 years ago

Original Bugzilla ID was 4174

Also available in: Atom PDF