Project

General

Profile

Bug #4195

Report Designer - 'Location aware' rendering of newly dropped panels.

Added by debi staggs about 10 years ago. Updated about 10 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
reporting
Target version:
Start date:
06/29/2009
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
4195

Description

Right now, when a user drops a report item onto a report, the report designer simply places the panel at the end (bottom) of the group of report items. If the user wants it somewhere else they then need to perform a second drag and drop to position it where they would like it to appear. It would be better if they could drag it to the approximate position where they would like to insert it, and have it show up at that position (when the layout is rendered) instead. Not sure if this is correctly targeted for the upcoming SanParks release, but will work on it as soon as any remaining higher priority items are complete.


Related issues

Is duplicate of Kepler - Bug #4208: Report Designer - dragging from the component window to the canvas does not drop where you want itResolved06/30/2009

History

#1 Updated by debi staggs about 10 years ago

  • Bug 4208 has been marked as a duplicate of this bug. ***

#2 Updated by debi staggs about 10 years ago

Moving this enhancement to the next release, since it will touch some of the core functionality of the report designer, and will require more time to complete and test.

#3 Updated by debi staggs about 10 years ago

When the user drops a report item onto the report, the item now places it where they have dropped it, and it no longer just puts it at the bottom. : )

#4 Updated by Redmine Admin over 6 years ago

Original Bugzilla ID was 4195

Also available in: Atom PDF