Project

General

Profile

Actions

Bug #422

closed

fix export functionality

Added by Dan Higgins over 22 years ago. Updated over 21 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
morpho - general
Target version:
Start date:
02/13/2002
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
422

Description

requested by REOT group

Actions #1

Updated by Dan Higgins over 22 years ago

already in Bugzill

Actions #2

Updated by Dan Higgins over 22 years ago

bug already in system

Actions #3

Updated by Dan Higgins over 22 years ago

should be resolve_duplicate

Actions #4

Updated by Dan Higgins over 22 years ago

I cannot find the duplicate right now. Will leave in system

Actions #5

Updated by Matt Jones about 22 years ago

In addition to returning the original filenames (after checking for naming
conflicts), we also need to produce an HTML export of the metadata that is
complete and easy to read. This should be based on the new EML XSLT stylesheets
linked together in a series.

Actions #6

Updated by Matt Jones almost 22 years ago

also make sure it works i the data package frame

Actions #7

Updated by Jing Tao almost 22 years ago

Also make sure synchronize and delete works in data package frame.

Actions #8

Updated by Jing Tao almost 22 years ago

I think this bug is redundant to bug 613. So I mark it as duplicate.

  • This bug has been marked as a duplicate of 613 ***
Actions #9

Updated by Matt Jones almost 22 years ago

Need to deal with Comment #5 where it was requested that data files be renamed
as they were originally when the data is exported. This necessitates a check
for file naming conflicts, as there is no guarantee that user-provided filenames
are unique.

Actions #10

Updated by Jing Tao over 21 years ago

Now after exporting a package, the data file will be stored in a saperate
directory - data and xml document will be stored in another subdirectory -
metadata. The data file's name will be the original name rather than docid. If
the file's names have conflict, the second one will be add a character '1' at
the name. For example data and data1.
A style sheet - export.css is exported too. So the summary html file is looked
much better.

Actions #11

Updated by Redmine Admin over 11 years ago

Original Bugzilla ID was 422

Actions

Also available in: Atom PDF