Project

General

Profile

Bug #4255

Add Online Javadocs

Added by Chad Berkley about 10 years ago. Updated about 10 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
build system
Target version:
Start date:
07/21/2009
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
4255

Description

We need to add the javadocs for released versions of kepler to the website.

kepler-javadoc.sh (378 Bytes) kepler-javadoc.sh Chad Berkley, 07/24/2009 12:11 PM

History

#2 Updated by Chad Berkley about 10 years ago

The javadocs for the latest nightly build are now here:
http://dist.kepler-project.org/dist/nightly/javadoc/

The nightly build uploads the javadocs in a tar file to the kepler-project.org server, then a cron job runs every day at 6 am. It finds the newest javadoc tar file and untars it in the javadoc directory. The shell script can be found at /var/www/org.kepler-project.www. I've attached the shell script for posterity's sake since it is not checked into svn.

#3 Updated by Christopher Brooks about 10 years ago

I ported a version of ptolemy.util.StreamExec to
build-area/src/org/kepler/build/util/StreamSingleCommandExec.java
and modified CreateJavadoc.java to use it and the problem with
running javadoc on the ptolemy classes goes away.

I suspect that the problem is that both org.kepler.build.util.CommandLine
and org.apache.tools.ant.taskdefs.Javadoc are incorrectly handling
stderr output from the subprocess. StreamSingleCommandExec creates two
threads to read stdout and stderr.

I also added the Rating Taglet so that running javadoc on the ptolemy
code does not produce output like:
warning - @Pt.AcceptedRating is an unknown tag.

There are a few problems though:
1) We are not properly excluding directories like ptolemy/vendors.
If the ant taskdefs.Javadoc class worked properly, then maybe we could
use the ant exclude facility here?
2) Various third party packages such as the Apache Logging facility
are not included in the CLASSPATH so we get error messages.

#4 Updated by Christopher Brooks about 10 years ago

Whoops, comment #3 was appended to the wrong javadoc bug
My comment #3 was meant for bug #4259: Fix the 'ant javadoc' command
http://bugzilla.ecoinformatics.org/show_bug.cgi?id=4259

#5 Updated by Redmine Admin over 6 years ago

Original Bugzilla ID was 4255

Also available in: Atom PDF