Project

General

Profile

Bug #4278

Changes to a reopened KAR are not saved to the new KAR

Added by ben leinfelder almost 10 years ago. Updated almost 10 years ago.

Status:
Resolved
Priority:
Immediate
Assignee:
Category:
core
Target version:
Start date:
08/03/2009
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
4278

Description

First encountered this in south africa:
-make a new workflow
-save as kar
-close
-open kar
-edit workflow
-save as kar again
-close
-open kar
Changes are gone - still the same as the first save.


Related issues

Blocked by Kepler - Bug #4197: Waterflow TPC demo - tracking bugResolved06/29/2009

Blocked by Kepler - Bug #3672: Open/Save Workflow as KAR ArchiveResolved11/13/2008

Blocked by Kepler - Bug #4361: Workflow Run Manager column "Workflow Name" can be confusingNew08/31/2009

History

#1 Updated by ben leinfelder almost 10 years ago

one thing that I noticed was that when resaving to a KAR with the same file name, I did not see any indication (in the console/logs) of the workflow/roml being serialized. Perhaps it sees that this kar has been cached and does nothing? There's definitely something going on with the caching here.

#2 Updated by Aaron Aaron almost 10 years ago

This bug is fixed in the Kepler suite, it still has problems in the WRP suite because RIOs do not get cached/saved properly and so the KAR file is not getting saved...

#3 Updated by ben leinfelder almost 10 years ago

I tried running this in the 'kepler' suite and still had the same behavior. Here is what I did:
-open existing demo workflow
-save as KAR
-close workflow
-open saved KAR file
-remove an actor from the canvas
-save as KAR (overwrite same kar file)
-close workflow
-open KAR
Workflow still has my deleted actor

#4 Updated by ben leinfelder almost 10 years ago

Also tried saving the modified workflow to a different .kar file, but the changes are still lost when i open the new file.

#5 Updated by Aaron Aaron almost 10 years ago

yes this is ok now in the kepler suite

#6 Updated by Redmine Admin about 6 years ago

Original Bugzilla ID was 4278

Also available in: Atom PDF