Project

General

Profile

Actions

Bug #3672

closed

Open/Save Workflow as KAR Archive

Added by Aaron Aaron over 15 years ago. Updated over 14 years ago.

Status:
Resolved
Priority:
Immediate
Assignee:
Category:
core
Target version:
Start date:
11/13/2008
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
3672

Description

Workflow fails to be imported from a kar file

I do the following
File->Open File
Choose getting-started/01-SimpleAddition.xml
Then from the File menu of the SimpleAddition workflow
Choose "Export Workflow as Archive (KAR)" and save it somewhere
Close the SimpleAddition workflow
The choose File->Import Archive (KAR)
and navigate to the saved kar file and open it
An error is shown:
"There are no semantic types defined for the actor in this KAR file. Without a semantic type, it cannot be placed in the tree. Please add a semantic type."


Related issues

Blocked by Kepler - Bug #4001: WRP - Save/Open KARs containing MOMLs and ROMLsResolvedben leinfelder04/20/2009

Actions
Blocks Kepler - Bug #4278: Changes to a reopened KAR are not saved to the new KARResolvedAaron Aaron08/03/2009

Actions
Blocks Kepler - Bug #4334: Rename actor from canvasResolvedAaron Aaron08/26/2009

Actions
Blocks Kepler - Bug #4322: Attempting to save changes to a workflow saved in a KAR file failsResolvedAaron Aaron08/18/2009

Actions
Blocked by Kepler - Bug #4361: Workflow Run Manager column "Workflow Name" can be confusingNewDerik Barseghian08/31/2009

Actions
Actions #1

Updated by Derik Barseghian over 15 years ago

This is very similar to bug #3595, which is the same message but to do with the importing of just an actor kar.

See also discussion in this thread: http://mercury.nceas.ucsb.edu/ecoinformatics/pipermail/kepler-users/2008-November/000594.html

Actions #2

Updated by ben leinfelder over 14 years ago

we absolutely need to Save and Open KARs that contain:
-1 workflow (MOML)
-1 report layout (ROML)

Actions #3

Updated by ben leinfelder over 14 years ago

related to other bug that is slightly reporting-specific.
same functionality, however

Actions #4

Updated by ben leinfelder over 14 years ago

this is not actually a bug about "Opening" a workflow - it has to do with "Importing"
I'd previously misunderstood. Re-target to 2.0 (unless it's actually fixed?)

Actions #5

Updated by Chad Berkley over 14 years ago

For this bug to be closed, the following functionality should work:

  • Save a kar locally and to the local repository
  • Upload a kar to a remote repository
  • Import an existing kar into the library
  • Any LSID conflicts should be handled.

Aaron, are we there yet? It seems like at least most of this was working for the sanparks release.

Actions #6

Updated by Matt Jones over 14 years ago

Import/Export of KARs is now really the Save function, so should be named as such in the menus. Plus complete items from Comment #5.

Actions #7

Updated by ben leinfelder over 14 years ago

I just tried a Save as KAR then Open KAR and got a ClassCastException: looks like we're expecting a KarEntry (a subclass) but getting a JarEntry (the superclass). Workflow doesn't open after this exception is thrown.

Actions #8

Updated by Aaron Aaron over 14 years ago

works now

Actions #9

Updated by Redmine Admin almost 11 years ago

Original Bugzilla ID was 3672

Actions

Also available in: Atom PDF