Project

General

Profile

Bug #4280

ant task fails under Windows

Added by Christopher Brooks almost 10 years ago. Updated over 9 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
build system
Target version:
Start date:
08/05/2009
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
4280

Description

ant task fails under Window.

bash-3.2$ svn co https://code.kepler-project.org/code/kepler/trunk/modules/build-area
...
bash-3.2$ cd build-area
bash-3.2$ ant -version
Apache Ant version 1.7.1 compiled on June 27 2008
bash-3.2$ uname -a
CYGWIN_NT-5.2 newton 1.5.25(0.156/4/2) 2008-06-12 19:34 i686 Cygwin
bash-3.2$ ant task
Buildfile: build.xml

task:

clean:
[delete] Deleting: c:\tmp\cxh\src\kepler\build-area\target\kepler-tasks.jar

BUILD FAILED
c:\tmp\cxh\src\kepler\build-area\build.xml:197: The following error occurred while executing this line:
c:\tmp\cxh\src\kepler\build-area\kepler-tasks.xml:6: Unable to delete file c:\tmp\cxh\src\kepler\build-area\target\kepler-tasks.jar

Total time: 0 seconds
bash-3.2$

The problem is that Windows is a toy operating system with a toy file
system that does not allow the deletion of open files. I think Unix
had this solved in the 1970's :-)

I'm not sure about a workaround here, since ant is a java process and
kepler-tasks.jar is in the CLASSPATH.

If we had tests of the build system, presumably this bug would have been caught.

History

#1 Updated by David Welker over 9 years ago

Again, "ant task" is a convenience short cut for:

ant -f kepler-tasks.xml

Therefore, I do not intend on devoting any resources to making this more robust. The "ant task" command is only useful to those who are working on the build system itself. Build system developers should know the alternative command in case "ant task" fails to work.

#2 Updated by Redmine Admin about 6 years ago

Original Bugzilla ID was 4280

Also available in: Atom PDF