Project

General

Profile

Bug #4297

Kepler needs a new layout manager.

Added by David Welker almost 10 years ago. Updated almost 10 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
core
Target version:
Start date:
08/07/2009
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
4297

Description

The layout manager we currently use fails miserably when run in Linux. If you try to resize Kepler, the canvas and other parts of Kepler are not resized sensibly.


Related issues

Has duplicate Kepler - Bug #4285: workflow canvas does not repack to fill empty space when top window is resizedNew08/07/2009

Blocked by Kepler - Bug #4286: Changes to the GUI before 2.0Resolved08/07/2009

History

#1 Updated by Christopher Brooks almost 10 years ago

We should follow the Java i18n standard of managing internationalization
strings, see
http://java.sun.com/javase/technologies/core/basic/intl/

The primary issue is that resources such as field names or button names
are stored in a standard i18n resource bundle.

Is this something we want to do by 2.0.0? Seems like a big job.

#2 Updated by Christopher Brooks almost 10 years ago

Duplicate of
http://bugzilla.ecoinformatics.org/show_bug.cgi?id=4285

  • This bug has been marked as a duplicate of bug 4285 ***

#3 Updated by Redmine Admin over 6 years ago

Original Bugzilla ID was 4297

Also available in: Atom PDF