Project

General

Profile

Bug #4338

need to review usability and gui of module manager

Added by Matt Jones over 9 years ago. Updated about 9 years ago.

Status:
Resolved
Priority:
Immediate
Assignee:
Category:
general
Target version:
Start date:
08/26/2009
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
4338

Description

The module manager is complete and functioning, but has not been reviewed by the broader community. Because it is a critical component and a fundamental part of the 2.0 release, we need to review its usability and design to be sure we are ready to ship. To close this bug, at least 5 people should review the module manager and verify that:

1) The user interface is usable and intuitive
1a) Modules are listed, with a brief description of each module
1b) Users can easily install & uninstall modules
1c) The module list can be searched to filter the list
2) The module manager can display new modules as they are published
3) The module manager can upgrade modules that are updated
4) The module manager can be configured to automatically find and download patch upgrades when they are available

Please post a comment here if you have reviewed these issues, stating which of the above list are satisfied, and any other comments.


Related issues

Blocked by Kepler - Bug #4009: kepler 2.0 must provide everything needed for modulesResolved2009-04-21

History

#1 Updated by Chad Berkley over 9 years ago

We also need to check to make sure that the module manager can successfully upgrade existing modules without breaking the current kepler installation.

#2 Updated by jianwu jianwu over 9 years ago

We also need to check:
1) whether the module manager can display new suites as they are published, switch suites easily.
2) add/configure other module repositories from module manager GUI.

One suggestion for current usability is the downloading process bar. In my current tests, needed modules are downloaded by Module Manger. Yet there is not a total process bar showing the total download percentage, only multiple process bars show up one-by-one when downloading each modules. I thought the whole downloading is finished and closed module manger when the first process bar finished and disappeared.

#3 Updated by Chad Berkley over 9 years ago

I've reviewed the module manager and these are the things I've noticed:

  • the window opens too small on OSX. It should be ~200px wider.
  • like jianwu said, the progress monitors show each individual download, but not the entire download. Either the dialog should be greyed out until the full download completes, or there should be a full progress bar.
  • There seems to be a bug where if I select a few modules to download, then click the "retrieve" button, the first module is not removed from the gui "selected modules" list.
  • I did a "change-to" on an available suite. It was about 10% done with downloading ptolemy, but then displayed a "done downloading modules" dialog.
  • After running the change-to, get this exception (and kepler crashes):

[run] java.io.EOFException: Unexpected end of ZLIB input stream
[run] at java.util.zip.InflaterInputStream.fill(InflaterInputStream.java:223)
[run] at java.util.zip.InflaterInputStream.read(InflaterInputStream.java:141)
[run] at java.util.zip.ZipInputStream.read(ZipInputStream.java:146)
[run] at org.kepler.modulemanager.AvailableModulesPanel.unzipHelper(AvailableModulesPanel.java:251)
[run] at org.kepler.modulemanager.AvailableModulesPanel.unzip(AvailableModulesPanel.java:214)
[run] at org.kepler.modulemanager.AvailableModulesPanel.downloadModules(AvailableModulesPanel.java:161)
...

  • when I try to restart kepler I get:
    [run] Exception in thread "main" java.lang.NoClassDefFoundError: org/kepler/Kepler
    [run] Caused by: java.lang.ClassNotFoundException: org.kepler.Kepler
    [run] at java.net.URLClassLoader$1.run(URLClassLoader.java:200)

#4 Updated by Chad Berkley over 9 years ago

turns out it changed my modules.txt to this:

berkley@Slickrock build-area$ more modules.txt
ssh-1.0.0

#5 Updated by Chad Berkley over 9 years ago

I tried the MM again from a clean build. I was able to change-to the kepler-1.0.0 suite, however there are some problems. No actors appear in the actor library. i ran an ant clean-cache which seemed to fix the problem. I think this is described in bug 4587. I also noticed that the modules.txt file in kepler-1.0.0/module-info/ has a bunch of weird characters in it. There are carrots after each line. Is this on purpose? It doesn't seem to affect build, but it looks weird.

When restarting kepler with ant, it seems extremely slow after using the MM to change to kepler-1.0.0

Why is this suite called kepler-1.0.0? It does not actually change to kepler 1.0. This looks like Kepler 1.x dev. I think the versioning is confusing.

#6 Updated by Chad Berkley about 9 years ago

I've finished reviewing this and I think it's working well now. I don't see any real problems with it. getting modules and suites works well and changing to a suite also works, although the restart is a bit slow with no progress monitoring, but I think that would be hard to implement. Closing this bug. Open new bugs for issues related to module manager.

#7 Updated by Redmine Admin almost 6 years ago

Original Bugzilla ID was 4338

Also available in: Atom PDF