Project

General

Profile

Bug #4410

Cannot open KARs from arbitrary location on disk

Added by Derik Barseghian almost 10 years ago. Updated almost 10 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
general
Target version:
Start date:
09/24/2009
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
4410

Description

You cannot open a KAR from an arbitrary location on disk, it must reside in a local repository.

One work-around is to create a dialog that prompts the user to move such a KAR into a local repo when they try to open it.

If we're going to keep this restriction in place, I would also think the Save Archive dialog shouldn't allow, or at least make difficult, the saving of KARs in locations besides local repositories.


Related issues

Is duplicate of Kepler - Bug #4381: Open KAR: needs to work when opening from outside the /workflows directoryResolved09/11/2009

History

#1 Updated by ben leinfelder almost 10 years ago

I would really like to be able to open a KAR from anywhere. This seems like a trivial enhancement - but one that buys us a lot in terms of user satisfaction. Even if all you do during the open is first copy the selected KAR to a local repository and go from there.

#2 Updated by Aaron Aaron almost 10 years ago

Hmmm, another solution is to allow the opening of kars from outside the local repositories. But the next time you open kepler the kar would not be available in the cache.

#3 Updated by Aaron Aaron almost 10 years ago

  • Bug 4381 has been marked as a duplicate of this bug. ***

#4 Updated by Derik Barseghian almost 10 years ago

I vote, and am moving to, wrp-modules-1.0.0 target for this bug.

#5 Updated by ben leinfelder almost 10 years ago

this can also be problematic when we use the "remote execution" version of Kepler because it forces us to either configure our Kepler instance to use the temporary directory where we download KARs or to download them to the default local repository.

#6 Updated by Derik Barseghian almost 10 years ago

r21539 should fix this, going to leave open for a bit for others to test...

#7 Updated by ben leinfelder almost 10 years ago

I tried this (after the fix) but I'm not able to use the command line to open/run the KAR that is not in the local repository.

[run] WARN  (org.kepler.kar.KARFile:cacheKARContents:486) KAR must be in a Local Repository Folder to be inserted in the cache: /Users/leinfelder/workspace_kepler/kruger/workflows/tpc01-buffalo-tb/tpc01-buffalo-tb.kar

#8 Updated by ben leinfelder almost 10 years ago

only printing a warning message when the KAR is being cached from a non-local repository location.

#9 Updated by Redmine Admin over 6 years ago

Original Bugzilla ID was 4410

Also available in: Atom PDF