Project

General

Profile

Bug #4436

composite actor output ports cannot be added to reports

Added by Oliver Soong over 9 years ago. Updated over 9 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
reporting
Target version:
Start date:
10/06/2009
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
4436

Description

If I have a composite actor with an output port, I cannot add that output port to the report design template. I can add the output port that feeds the composite actor's output port. See attached workflow for an example.

Composite output.xml (21.9 KB) Composite output.xml Oliver Soong, 10/06/2009 12:26 PM

Related issues

Is duplicate of Kepler - Bug #4598: particular workflow triggers "QueryException: No tokens found for execution"Resolved12/03/2009

History

#2 Updated by ben leinfelder over 9 years ago

while inconvenient, it sounds like you can still get the Token that passes through this port. sort of a "work around" but better than not being able to report on it at all.

I would like to know: a) why the port cannot be added to the design template; b) if we get past that if provenance actually keeps track of that port (and it's tokens) as we need it to.

#3 Updated by ben leinfelder over 9 years ago

Did some more investigation:
-we can allow CompositeActor ports to be added to the report layout, but provenance isn't recording those tokens.
-if provenance records them, there's a line in ReportDesignerPanel that we can uncomment to allow dropping of those ports onto the layout
-in the meantime it's safe to "report on" either the port that feeds the CompositeActor port or the port that sinks that CompositeActor port

#5 Updated by Redmine Admin about 6 years ago

Original Bugzilla ID was 4436

Also available in: Atom PDF