Project

General

Profile

Bug #4507

report designer losing content when there are too many items

Added by Oliver Soong over 9 years ago. Updated over 9 years ago.

Status:
Resolved
Priority:
Immediate
Assignee:
Category:
reporting
Target version:
Start date:
10/27/2009
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
4507

Description

If I have a lot of items in the report designer, the scroll bar seems to be too short for the content. Eventually, there are figures that are above and below the scrollable area and are not accessible. They still show up in reports, though.

History

#1 Updated by Oliver Soong over 9 years ago

This is looking somewhat more serious. It seems like the report is actually losing content when it no longer fits into the scroll area.

#2 Updated by Oliver Soong over 9 years ago

A test case is pretty simple. Put an RExpression on the canvas, then keep dragging the port into the report designer. I like to add numbers to the caption so I know which is which. I lost 1 after adding 9. It's not in the ROML.

#3 Updated by debi staggs over 9 years ago

Just needed to dynamically re-size the scrolling pane in the layout panel, and it fixed the problem.

#4 Updated by Oliver Soong over 9 years ago

This doesn't quite seem to be fully fixed. I'm no longer losing report items from the test case, but add 15 items to the report instead of 9, and it still occurs. This is reproducible at r21772 on linux and XP. Not sure about OS X.

#5 Updated by debi staggs over 9 years ago

I just put 26 items in the report designer and there were no issues on OSX.

#6 Updated by debi staggs over 9 years ago

I just tested it with 26 items in the report designer and there were no problems on OSX.

#7 Updated by debi staggs over 9 years ago

I just tested it with 26 items on OSX, and it seems to be working correctly.

#8 Updated by Oliver Soong over 9 years ago

I just tried r21780 on OS X here in the vis lab and lost ROML content at 10 items. Something isn't matching here...

#9 Updated by debi staggs over 9 years ago

Will test it out on a different machine to see what happens.

#10 Updated by Derik Barseghian over 9 years ago

I've been able to get this to happen on my mac (10.5.8) -- at least the part
about having more items on the report designer than I can scroll to. I haven't
looked at the reports to see if they are missing results.
Once I had trouble getting it to happen, not sure the details. It seems like
adding a bunch of items between others, instead of to the end, might be a good
way to get it to occur. Also I notice the topmost item starts to look scrunched
up when this happens...different from the last-visible at the bottom which is often just partially visible.

#11 Updated by Oliver Soong over 9 years ago

Beyond 5 items, I can no longer add to the bottom of the report designer. There doesn't seem to be any space, and anything I drop doesn't seem to show up, so I have to add to the middle to get more than 5.

#12 Updated by debi staggs over 9 years ago

I have a feeling that you might not have the latest revision of the ReportDesignerPanel class, can you try updating or better yet do a fresh checkout ?

#13 Updated by Oliver Soong over 9 years ago

I'm at r21647 for report\src\org\kepler\reporting\gui\ReportDesignerPanel.java. I saw you just committed 2 updates, but from the log, they don't sound particularly important.

I'll see what a fresh checkout will do.

#14 Updated by Oliver Soong over 9 years ago

I see the problem as described at r21780, but at r21788, the number of actors is pushed up to around 95 or so. The problem still exists, but it becomes less bothersome.

#15 Updated by debi staggs over 9 years ago

Does everyone think that this is acceptable at 95 items, or so, or should I consider creating a 'buffer' that would create a kind of 'paging' of the report in memory and then scroll to a certain 'viewable' number of items. This is kind of involved, but do-able. Not sure about the time-frame for writing it + testing.
What do you guys think ? Should we should close this bug for now ? or ... ?

#16 Updated by Oliver Soong over 9 years ago

I'm not currently planning on exceeding 95 items, so there's less urgency for a more involved fix. On the other hand, the problem isn't actually fixed, so I would either leave it open or resolve as WONTFIX or LATER.

#17 Updated by debi staggs over 9 years ago

It would be nice to make this more flexible, but it isn't absolutely necessary at this time. However, it would be good if this were addressed in the future, as I think 'paging' was originally called out in the design documents as a feature for a possible future release.

#18 Updated by Redmine Admin over 6 years ago

Original Bugzilla ID was 4507

Also available in: Atom PDF