Project

General

Profile

Bug #4599

changing Expression and running problematic workflow generates blank report

Added by Oliver Soong about 10 years ago. Updated almost 10 years ago.

Status:
Resolved
Priority:
Normal
Category:
provenance
Target version:
Start date:
12/03/2009
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
4599

Description

This uses the same workflow in Bug 4598. Open the workflow and change the "Figure Number" Expression from 1 to 12. Run the workflow and view the output. It should be a single blank page with a time/date stamp at the bottom.


Related issues

Blocks Kepler - Bug #4601: New LSID not propagating to provenanceResolved12/03/2009

History

#1 Updated by ben leinfelder about 10 years ago

Here's the scenario:
1. KAR/Workflow from another Kepler installation is opened - you can run it once and everything (reporting) works fine.
2. Modifying the workflow assigns and entirely new LSID because you are not the same AuthInstanceNamespace.
3. Execute again and provance records this execution with the original (first opened) LSID.

So it seems that the new LSID assignment isn't getting propagated to the provenance recorder.

#2 Updated by Daniel Crawl almost 10 years ago

Fixed.

#3 Updated by Oliver Soong almost 10 years ago

Not quite fixed. I still get the blank report. I'm at r22136.

#4 Updated by Oliver Soong almost 10 years ago

Still happening at r22183. There might be more to it than the provenance recorder?

#5 Updated by Oliver Soong almost 10 years ago

Until this gets fixed, a workaround is to give the workflow an LSID from the local Kepler install. Basically, delete an actor, undo, then save and reload.

#6 Updated by ben leinfelder almost 10 years ago

okay - now when the LSID is changed, the layout manager listens for the change event and reassociates the layout with the workflow using the new id.

#7 Updated by Redmine Admin over 6 years ago

Original Bugzilla ID was 4599

Also available in: Atom PDF