Project

General

Profile

Bug #4605

Semantic Annotation NPE

Added by Derik Barseghian over 9 years ago. Updated over 9 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
semantics
Target version:
Start date:
12/07/2009
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
4605

Description

If you File=> Save Achive (KAR), and say yes to semantically annotate it, you get an NPE:

Exception in thread "AWT-EventQueue-0" java.lang.NullPointerException: name
at java.util.zip.ZipFile.getEntry(ZipFile.java:247)

This happens during Export Run in the WRM too.

Also: I believe we decided we can probably just do away with the semantic annotate warning dialog since the Tagging interface now exists and tagging is more apparent to the user.


Related issues

Is duplicate of Kepler - Bug #4626: NPE when saying "yes" to adding a semantic type while saving a KARResolved12/10/2009

History

#1 Updated by Derik Barseghian over 9 years ago

I guess since we don't have Tagging in the vanilla Kepler suite, we still need to warn the user if they haven't semantically annotated an object in ExportArchiveAction. But in ExportRunsArchiveAction we don't need to require this, since the tagging interface exists...

#3 Updated by Aaron Aaron over 9 years ago

Somehow OntoClassSelectionJPanel is not in the classpath at runtime... It gets used from ActorSemanticTypeEditorPane but the Classloader never finds it, even though it's in the same package, in the same module.

#4 Updated by Aaron Aaron over 9 years ago

Turns out it was just unable to find the icon, which was crashing the whole thing (not good). Fixed now.

#5 Updated by Redmine Admin about 6 years ago

Original Bugzilla ID was 4605

Also available in: Atom PDF