Project

General

Profile

Bug #4657

morpho creates <keyword> elements out of keywordType attribute content

Added by Margaret O'Brien over 10 years ago. Updated over 10 years ago.

Status:
Resolved
Priority:
Normal
Category:
morpho - general
Target version:
Start date:
01/08/2010
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
4657

Description

the <keyword> element has an optional attribute keywordType, as in this snippet from knb-lter-sbc.17.12

<keywordSet>
<keyword keywordType="theme">Santa Barbara Coastal</keyword>
<keyword keywordType="theme">LTER</keyword>
</keywordSet>

EML created by Morpho does not include this attribute, but when Morpho encounters one, it takes the attribute content and moves it to a keyword element, yielding a node like this (knb-lter-sbc.17.13):
<keywordSet>
<keyword>theme</keyword>
<keyword>Santa Barbara Coastal</keyword>
<keyword>theme</keyword>
<keyword>LTER</keyword>
</keywordSet>

So now we have extra erroneous keywords, and no keywordType attributes.
Morpho seems to do this as soon as it reads the EML in, since the extra keywords show up immediately.

Note: this data set is still EML201, and so was was edited with Morpho 1.6.1. I confirmed the behavior with Morpho 1.7 and a local test dataset.

History

#1 Updated by ben leinfelder over 10 years ago

is there a docid that hasn't yet been corrected?

#2 Updated by ben leinfelder over 10 years ago

simple solutions:
-pop up the tree editor when we encounter keywordType attributes
-remove them and carry one with the wizard page

harder:
-ignore them, but keep them with the keyword they correspond to. but if you can't see the keywordType, then and you edit the text of a keyword do you keep the same keywordType?

#3 Updated by Margaret O'Brien over 10 years ago

Good point, Ben - that if Morpho ignore the keywordType element, how does the user know an edited keyword still has the same type.

So, 2 things:
1. this suggests one of the simple fixes. The general morpho user will not want to encounter the tree editor, so dropping the keywordType attribute is preferred. Generally, I loathe dropping information, but in this case it might represent not-so-usable information ... (see note 2)

2. this reminds me of a recent discussion among some EML authors, about the EML keyword nodes. In general, it was thought that the current spec -- a restrictive keywordType list for the keyword itself but no id attribute for the keywordSet -- was limiting and not particularly usable.

So dropping the keywordType attribute is acceptable. Those people with applications making use of it cannot be using morpho-originated documents anyway.

#4 Updated by ben leinfelder over 10 years ago

the keywordType attribute will now be preserved behind the scenes when editing with the wizard interface.

#5 Updated by Redmine Admin over 7 years ago

Original Bugzilla ID was 4657

Also available in: Atom PDF