Project

General

Profile

Bug #4800

CacheManager can not insert WorkflowRun into cache

Added by Derik Barseghian about 9 years ago. Updated almost 9 years ago.

Status:
Resolved
Priority:
Normal
Category:
workflow run manager
Target version:
Start date:
02/17/2010
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
4800

Description

When you export a run, CacheManager's insertObject cannot insert WorkflowRun entries into cache. This is because the call to serializeObjectInFile fails, caused by:

Caused by: java.io.NotSerializableException: java.lang.ref.WeakReference
at java.io.ObjectOutputStream.writeObject0(ObjectOutputStream.java:1081)
at java.io.ObjectOutputStream.writeObject(ObjectOutputStream.java:302)


Related issues

Blocked by Kepler - Bug #4619: WorkflowRuns not showing inside KARs in libraryResolved2009-12-09

History

#1 Updated by Derik Barseghian almost 9 years ago

I believe this is fixed. Aaron, do you consider this fixed with r23291?

#2 Updated by Aaron Aaron almost 9 years ago

Yes, the solution to use moml as the serialization format to cache instead of a java serialized object seems to be working well.

#3 Updated by Redmine Admin almost 6 years ago

Original Bugzilla ID was 4800

Also available in: Atom PDF