Project

General

Profile

Bug #4846

error opening kar from local repository

Added by Oliver Soong about 9 years ago. Updated almost 7 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
general
Target version:
Start date:
02/25/2010
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
4846

Description

This is with wrp at r23202. I deleted .kepler and KeplerData. I create a trivial workflow (default SDF and RExpression) and save it as a KAR in the default local repository. On restarting Kepler, the KAR and local repository are not listed in the components pane. If I go into Sources and manually trigger a re-build of the component library, I can see the KAR, but nothing happens when I attempt to open it (right-click menu) except an error in the console:

org.kepler.objectmanager.cache.CacheException: Exception occurred while deserializing object
at org.kepler.objectmanager.cache.CacheManager.getObject(CacheManager.java:529)
at org.kepler.kar.handlers.ActorMetadataKAREntryHandler.open(ActorMetadataKAREntryHandler.java:206)
at org.kepler.kar.KARFile.open(KARFile.java:889)
at org.kepler.kar.KARFile.openKARContents(KARFile.java:665)
at org.kepler.gui.kar.OpenArchiveAction.openKAR(OpenArchiveAction.java:162)
at org.kepler.gui.kar.OpenArchiveAction.actionPerformed(OpenArchiveAction.java:143)
at javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:1995)
at javax.swing.AbstractButton$Handler.actionPerformed(AbstractButton.java:2318)
at javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:387)
at javax.swing.DefaultButtonModel.setPressed(DefaultButtonModel.java:242)
at javax.swing.AbstractButton.doClick(AbstractButton.java:357)
at javax.swing.plaf.basic.BasicMenuItemUI.doClick(BasicMenuItemUI.java:1223)
at javax.swing.plaf.basic.BasicMenuItemUI$Handler.mouseReleased(BasicMenuItemUI.java:1264)
at java.awt.Component.processMouseEvent(Component.java:6263)
at javax.swing.JComponent.processMouseEvent(JComponent.java:3255)
at java.awt.Component.processEvent(Component.java:6028)
at java.awt.Container.processEvent(Container.java:2041)
at java.awt.Component.dispatchEventImpl(Component.java:4630)
at java.awt.Container.dispatchEventImpl(Container.java:2099)
at java.awt.Component.dispatchEvent(Component.java:4460)
at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4574)
at java.awt.LightweightDispatcher.processMouseEvent(Container.java:4238)
at java.awt.LightweightDispatcher.dispatchEvent(Container.java:4168)
at java.awt.Container.dispatchEventImpl(Container.java:2085)
at java.awt.Window.dispatchEventImpl(Window.java:2475)
at java.awt.Component.dispatchEvent(Component.java:4460)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:599)
at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:269)
at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:184)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:174)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:169)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:161)
at java.awt.EventDispatchThread.run(EventDispatchThread.java:122)
Caused by: java.io.IOException: Error in ActorCacheObject(ReadExternal): null
at org.kepler.objectmanager.cache.ActorCacheObject.readExternal(ActorCacheObject.java:250)
at java.io.ObjectInputStream.readExternalData(ObjectInputStream.java:1792)
at java.io.ObjectInputStream.readOrdinaryObject(ObjectInputStream.java:1751)
at java.io.ObjectInputStream.readObject0(ObjectInputStream.java:1329)
at java.io.ObjectInputStream.readObject(ObjectInputStream.java:351)
at org.kepler.objectmanager.cache.CacheManager.getObject(CacheManager.java:517)
... 32 more

History

#1 Updated by Oliver Soong about 9 years ago

I just noticed, but I'm getting 2 of these errors every time I save to the local repository:

ERROR (org.kepler.objectmanager.library.LibraryManager:assureTreeItem:308) Error while adding Tree Item

#2 Updated by Oliver Soong about 9 years ago

I also noticed that, after restarting Kepler, the KAR and local repository are listed in the components pane, but the entries are no longer sorted. The "Workflows" entry occurs first, rather than last, where I expected it. In any case, the error message still occurs when attempting to open the workflow.

#3 Updated by Daniel Crawl almost 7 years ago

This has been fixed for awhile.

#4 Updated by Redmine Admin about 6 years ago

Original Bugzilla ID was 4846

Also available in: Atom PDF