Project

General

Profile

Bug #4991

Kepler-2.0-RC2 fails to start for a non-admin user after admin install

Added by Christopher Brooks about 9 years ago. Updated about 9 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
installer
Target version:
Start date:
05/07/2010
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
4991

Description

I installed Kepler as admin under Windows 2003 and the installation works
fine.
If I try to start Kepler as a non-admin user, it appears to start up
and then exit?

Running kepler.bat as a non-admin user fails:

C:\PROGRA~1\Kepler-2.0-RC2>.\kepler.bat
Exception in thread "main" java.io.FileNotFoundException: C:\Program Files\Keple
r-2.0-RC2\build-area\present.txt (Access is denied)
at org.kepler.build.modules.ModulesTask.execute(ModulesTask.java:105)
at org.kepler.build.modules.Module.readPresent(Module.java:209)
at org.kepler.build.modules.Module.transformName(Module.java:296)
at org.kepler.build.modules.Module.<init>(Module.java:141)
at org.kepler.build.modules.Module.<init>(Module.java:186)
at org.kepler.build.modules.ModulesTxt.readHelper(ModulesTxt.java:148)
at org.kepler.build.modules.ModulesTxt.read(ModulesTxt.java:120)
at org.kepler.build.modules.ModulesTxt.init(ModulesTxt.java:57)
at org.kepler.build.modules.ModuleTree.init(ModuleTree.java:96)
at org.kepler.build.modules.ModulesTask.init(ModulesTask.java:86)
at org.kepler.build.runner.Kepler.main(Kepler.java:76)
Caused by: java.io.FileNotFoundException: C:\Program Files\Kepler-2.0-RC2\build-
area\present.txt (Access is denied)
at java.io.FileOutputStream.open(Native Method)
at java.io.FileOutputStream.<init>(FileOutputStream.java:179)
at java.io.FileOutputStream.<init>(FileOutputStream.java:131)
at java.io.FileWriter.<init>(FileWriter.java:73)
at org.kepler.build.UpdatePresentTxt.run(UpdatePresentTxt.java:66)
at org.kepler.build.modules.ModulesTask.execute(ModulesTask.java:101)
... 10 more
--- Nested Exception ---
java.io.FileNotFoundException: C:\Program Files\Kepler-2.0-RC2\build-area\presen
t.txt (Access is denied)
at java.io.FileOutputStream.open(Native Method)
at java.io.FileOutputStream.<init>(FileOutputStream.java:179)
at java.io.FileOutputStream.<init>(FileOutputStream.java:131)
at java.io.FileWriter.<init>(FileWriter.java:73)
at org.kepler.build.UpdatePresentTxt.run(UpdatePresentTxt.java:66)
at org.kepler.build.modules.ModulesTask.execute(ModulesTask.java:101)
at org.kepler.build.modules.Module.readPresent(Module.java:209)
at org.kepler.build.modules.Module.transformName(Module.java:296)
at org.kepler.build.modules.Module.<init>(Module.java:141)
at org.kepler.build.modules.Module.<init>(Module.java:186)
at org.kepler.build.modules.ModulesTxt.readHelper(ModulesTxt.java:148)
at org.kepler.build.modules.ModulesTxt.read(ModulesTxt.java:120)
at org.kepler.build.modules.ModulesTxt.init(ModulesTxt.java:57)
at org.kepler.build.modules.ModuleTree.init(ModuleTree.java:96)
at org.kepler.build.modules.ModulesTask.init(ModulesTask.java:86)
at org.kepler.build.runner.Kepler.main(Kepler.java:76)

C:\PROGRA~1\Kepler-2.0-RC2>

Running kepler.exe just returns.


Related issues

Blocked by Kepler - Bug #4943: RC5 Installer Tracking BugResolved04/19/2010

History

#1 Updated by David Welker about 9 years ago

This should now work.

#2 Updated by Redmine Admin about 6 years ago

Original Bugzilla ID was 4991

Also available in: Atom PDF