Project

General

Profile

Bug #5025

Couldn't run the workflows 00-StatisticalSummary and 08-CommandLine_2

Added by Jing Tao over 9 years ago. Updated over 9 years ago.

Status:
Resolved
Priority:
Normal
Category:
general
Target version:
Start date:
05/20/2010
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
5025

Description

On windows vista (With R 2.9) and windows 7 (With R 2.10.1), I got the errors:

1(00-StatisticalSummary):

ptolemy.kernel.util.IllegalActionException: There has been a problem running the R script!
It may be due to an error in your script, it may be that R is not
installed on your system, or it may not be on your path and cannot
be located by Kepler. Please make sure R is installed and the
R command line executable is in the path.For more information, see
section 8.2.2 of the Kepler User Manual.
in .00-StatisticalSummary.SummaryStatistics
Because:
java.lang.NullPointerException
at org.ecoinformatics.seek.R.RExpression.fire(RExpression.java:915)
at ptolemy.actor.AtomicActor.iterate(AtomicActor.java:469)
at ptolemy.actor.sched.StaticSchedulingDirector.fire(StaticSchedulingDirector.java:188)
at ptolemy.actor.CompositeActor.fire(CompositeActor.java:458)
at ptolemy.actor.Manager.iterate(Manager.java:749)
at ptolemy.actor.Manager.execute(Manager.java:351)
at ptolemy.actor.Manager.run(Manager.java:1162)
at ptolemy.actor.Manager$3.run(Manager.java:1215)
Caused by: java.lang.NullPointerException
at org.ecoinformatics.seek.R.RExpression.fire(RExpression.java:901)
... 7 more
Caused by: java.lang.NullPointerException
at org.ecoinformatics.seek.R.RExpression.fire(RExpression.java:901)
at ptolemy.actor.AtomicActor.iterate(AtomicActor.java:469)
at ptolemy.actor.sched.StaticSchedulingDirector.fire(StaticSchedulingDirector.java:188)
at ptolemy.actor.CompositeActor.fire(CompositeActor.java:458)
at ptolemy.actor.Manager.iterate(Manager.java:749)
at ptolemy.actor.Manager.execute(Manager.java:351)
at ptolemy.actor.Manager.run(Manager.java:1162)
at ptolemy.actor.Manager$3.run(Manager.java:1215)

2(08-CommandLine_2):

ptolemy.kernel.util.IllegalActionException: Problem executing the command ''
in the directory: C:\Users\tao\KeplerData\Kepler-2.0-Demos\demos\getting-started
in .08-CommandLine_2.External Execution
Because:
Cannot run program "R" (in directory "C:\Users\tao\KeplerData\Kepler-2.0-Demos\demos\getting-started"): CreateProcess error=2, The system cannot find the file specified
at ptolemy.actor.lib.Exec._exec(Exec.java:570)
at ptolemy.actor.lib.Exec.fire(Exec.java:320)
at ptolemy.actor.AtomicActor.iterate(AtomicActor.java:469)
at ptolemy.actor.sched.StaticSchedulingDirector.fire(StaticSchedulingDirector.java:188)
at ptolemy.actor.CompositeActor.fire(CompositeActor.java:458)
at ptolemy.actor.Manager.iterate(Manager.java:749)
at ptolemy.actor.Manager.execute(Manager.java:351)
at ptolemy.actor.Manager.run(Manager.java:1162)
at ptolemy.actor.Manager$3.run(Manager.java:1215)
Caused by: java.io.IOException: Cannot run program "R" (in directory "C:\Users\tao\KeplerData\Kepler-2.0-Demos\demos\getting-started"): CreateProcess error=2, The system cannot find the file specified
at java.lang.ProcessBuilder.start(Unknown Source)
at java.lang.Runtime.exec(Unknown Source)
at ptolemy.actor.lib.Exec._exec(Exec.java:550)
... 8 more
Caused by: java.io.IOException: CreateProcess error=2, The system cannot find the file specified
at java.lang.ProcessImpl.create(Native Method)
at java.lang.ProcessImpl.<init>(Unknown Source)
at java.lang.ProcessImpl.start(Unknown Source)
... 11 more
Caused by: java.io.IOException: Cannot run program "R" (in directory "C:\Users\tao\KeplerData\Kepler-2.0-Demos\demos\getting-started"): CreateProcess error=2, The system cannot find the file specified
at java.lang.ProcessBuilder.start(Unknown Source)
at java.lang.Runtime.exec(Unknown Source)
at ptolemy.actor.lib.Exec._exec(Exec.java:550)
at ptolemy.actor.lib.Exec.fire(Exec.java:320)
at ptolemy.actor.AtomicActor.iterate(AtomicActor.java:469)
at ptolemy.actor.sched.StaticSchedulingDirector.fire(StaticSchedulingDirector.java:188)
at ptolemy.actor.CompositeActor.fire(CompositeActor.java:458)
at ptolemy.actor.Manager.iterate(Manager.java:749)
at ptolemy.actor.Manager.execute(Manager.java:351)
at ptolemy.actor.Manager.run(Manager.java:1162)
at ptolemy.actor.Manager$3.run(Manager.java:1215)
Caused by: java.io.IOException: CreateProcess error=2, The system cannot find the file specified
at java.lang.ProcessImpl.create(Native Method)
at java.lang.ProcessImpl.<init>(Unknown Source)
at java.lang.ProcessImpl.start(Unknown Source)
... 11 more


Related issues

Blocked by Kepler - Bug #4943: RC5 Installer Tracking BugResolved04/19/2010

History

#1 Updated by David Welker over 9 years ago

Hmm... this isn't a problem for me with my Mac running R 2.10.1. Who else can reproduce this?

#2 Updated by Christopher Brooks over 9 years ago

I can run these demos as a non-admin user under Windows 2003 Server R2
with a Kepler-2.0-RC3 installation that was installed as admin.

Looking at the error message, it might be a problem that R is not in Jing's
path? The script runs the command "R --no-save". Jing, does that command
work for in a DOS shell? One other possibility could be that the
path to the R command has special characters in it. For example, under
Vista, the path could be something like "C:\Program Files (x64)" or some
other path that had parentheses in it.

#3 Updated by Derik Barseghian over 9 years ago

On my XP box w/ R 2.10.1:
00-StatisticalSummary - I have a different error when trying this workflow, it's described in bug#4985.
08-CommandLine_2 - I get the same error as Jing.

R --no-save doesn't work for me from a dos shell.

#4 Updated by Jing Tao over 9 years ago

It seems that R is not in the path.

C:\Users\tao>R --no-save
'R' is not recognized as an internal or external command,
operable program or batch file.

#5 Updated by Jing Tao over 9 years ago

After adding R into the path, those two workflows work.

So we have to make sure R was added into the path on my windows installer.

#6 Updated by Derik Barseghian over 9 years ago

After adding R to my PATH these workflows work for me as well. I'm going to take a look at the RExpression actor to see why the RExpression error message that warns you about R not being on your path isn't coming up...

#7 Updated by Derik Barseghian over 9 years ago

Error message about R not being on path should properly show now on trunk at r24573 and 2.0 at r24576. Leaving open for a bit more testing. One additional thing is that with or without this change, I'm currently getting an error only on 2.0 branch when trying to run a workflow that uses an RExpression...

#8 Updated by Derik Barseghian over 9 years ago

(In reply to comment #7)

Error message about R not being on path should properly show now on trunk at
r24573 and 2.0 at r24576. Leaving open for a bit more testing. One additional
thing is that with or without this change, I'm currently getting an error only
on 2.0 branch when trying to run a workflow that uses an RExpression...

This is on a 10.5 mac with R 2.10.1 with path set for R.

#9 Updated by Derik Barseghian over 9 years ago

(In reply to comment #8)

(In reply to comment #7)

Error message about R not being on path should properly show now on trunk at
r24573 and 2.0 at r24576. Leaving open for a bit more testing. One additional
thing is that with or without this change, I'm currently getting an error only
on 2.0 branch when trying to run a workflow that uses an RExpression...

This is on a 10.5 mac with R 2.10.1 with path set for R.

When using R 2.9.1 this doesn't happen. Jing installed R 2.10.1 with a dmg from the web, and this problem didn't happen for him on his 10.5 mac on kepler 2.0 (same setup as me). It's looking like there may be something wrong with my 2.10.1 install (even though nothing looks obviously wrong from cmd line). I'll reinstall 2.10.1 using macports, and if it still doesn't work, I'll try the dmg.

#10 Updated by Derik Barseghian over 9 years ago

(In reply to comment #9)

(In reply to comment #8)

(In reply to comment #7)

Error message about R not being on path should properly show now on trunk at
r24573 and 2.0 at r24576. Leaving open for a bit more testing. One additional
thing is that with or without this change, I'm currently getting an error only
on 2.0 branch when trying to run a workflow that uses an RExpression...

This is on a 10.5 mac with R 2.10.1 with path set for R.

When using R 2.9.1 this doesn't happen. Jing installed R 2.10.1 with a dmg from
the web, and this problem didn't happen for him on his 10.5 mac on kepler 2.0
(same setup as me). It's looking like there may be something wrong with my
2.10.1 install (even though nothing looks obviously wrong from cmd line). I'll
reinstall 2.10.1 using macports, and if it still doesn't work, I'll try the
dmg.

Reinstalling R 2.10.1 with macports didn't help.
Installing R 2.11.1 from the package on the R site worked.
Updating macports and installing R 2.11.1 also didn't work, for 2.0 or trunk, so I may have been wrong originally about this being a 2.0 only bug.

I would say we could close this if someone else can verify this problem with R installed via macports, and if we add messages to the relevant places (e.g. installer) saying to install R on the mac using the R site's installer.

#11 Updated by David Welker over 9 years ago

I agree that we should close this bug. I am gong to do so, but if anyone has any objections, feel free to re-open it.

My view is that we need to put how to handle installing R into the documentation and on the website. Perhaps we can also put documentation into the installer as well.

#12 Updated by Derik Barseghian over 9 years ago

(In reply to comment #10)

(In reply to comment #9)

(In reply to comment #8)

(In reply to comment #7)

Error message about R not being on path should properly show now on trunk at
r24573 and 2.0 at r24576. Leaving open for a bit more testing. One additional
thing is that with or without this change, I'm currently getting an error only
on 2.0 branch when trying to run a workflow that uses an RExpression...

This is on a 10.5 mac with R 2.10.1 with path set for R.

When using R 2.9.1 this doesn't happen. Jing installed R 2.10.1 with a dmg from
the web, and this problem didn't happen for him on his 10.5 mac on kepler 2.0
(same setup as me). It's looking like there may be something wrong with my
2.10.1 install (even though nothing looks obviously wrong from cmd line). I'll
reinstall 2.10.1 using macports, and if it still doesn't work, I'll try the
dmg.

Reinstalling R 2.10.1 with macports didn't help.
Installing R 2.11.1 from the package on the R site worked.
Updating macports and installing R 2.11.1 also didn't work, for 2.0 or trunk,
so I may have been wrong originally about this being a 2.0 only bug.

I would say we could close this if someone else can verify this problem with R
installed via macports, and if we add messages to the relevant places (e.g.
installer) saying to install R on the mac using the R site's installer.

I tried R 2.11.1 installed via macports on a 10.6 macbook last night, and it worked fine.
I also tried R 2.11.1 via macports on a different 10.5 macbook today, and it also worked.
So it looks like my issue above is somehow particular to R using macports on my main 10.5 machine.

So in summary, this bug can stay closed, and no need to add documentation warning a user to not install R with macports. A note saying they'll need to install R (including augmenting their PATH) for the R workflows would be good, but the R actor's error message will now come up again if that's not the case.

#13 Updated by Redmine Admin over 6 years ago

Original Bugzilla ID was 5025

Also available in: Atom PDF