Project

General

Profile

Bug #5063

Morpho Data Package Editor degrades when Editing Data Table Access

Added by Rick Reeves over 10 years ago. Updated over 10 years ago.

Status:
New
Priority:
Normal
Category:
morpho - general
Target version:
Start date:
06/29/2010
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
5063

Description

(Ben L. was an eyewitness to this - 6.29.2010)
Running Windows 7 Enterprise.
I have added six data objects/tables to an existing Morpho Data Package (knb.245.x) and am adding access permissions to each table using the
Data/Edit Data Table Access wizard. I add custom access permissions
for two individuals on the first three tables, clicking the OK button
at the bottom of each dialog but NOT saving the package between data
tables.

Problem: As I click through the Data Package Editor tabs corresponding
to each data table, Morpho performance slows dramatically, until, after
the third tab/table, Morpho has ground to a halt and I have to wait 5-10
minutes for the menu bar items to change from grey to black.

After one of these long waits, when I save the package (local), the save
takes about three minutes.

This makes it very difficult to move forward in a Data Package editing session.

Last week when a similar thing happened, the Metacat had crashed and
Morpho had locked up. But that did not happen in this case. Performance
is just incredibly slow.

RR

History

#1 Updated by ben leinfelder over 10 years ago

I don't have any degradation after editing data entity access for multiple data entities in knb.245 - on OS X 10.6. I'm not sure how or why this would be a Windows 7 bug.

#2 Updated by Redmine Admin over 7 years ago

Original Bugzilla ID was 5063

Also available in: Atom PDF