Project

General

Profile

Bug #5136

semantic type checker always returns error

Added by Matt Jones about 9 years ago. Updated almost 9 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
semantics
Target version:
Start date:
08/09/2010
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
5136

Description

Chris Weed reported:

When I apply a semantic type to an input and output port that are
connected, the semantic type checker always shows an error on the
semantic types. This looks like a bug in Kepler 2.0
Chris

I was able to verify this on my copy of Kepler 2.0.0 on Mac OS 10.6 running Kepler 2.0.0. To reproduce, choose a workflow, and annotate the input and output ports of two connected actors using the same term from one of the ontologies. Then look at the type check summary for that channel, and it will indicate that there is an error even though the semantic types display as identical.

History

#1 Updated by Sean Riddle almost 9 years ago

Fixed in r26458. This is caused by the transition to the new OWL API. The condition for a semantic type being compatible with another was whether it was a subset of the other or equivalent to the other. Under the old API, one of these calls must have evaluated to true, but under the new one, a class is considered to be neither a subset of, nor equivalent to, itself. I put in an additional condition to check for whether the classes are equal in order to catch that case.

#2 Updated by Redmine Admin over 6 years ago

Original Bugzilla ID was 5136

Also available in: Atom PDF