Project

General

Profile

Bug #5184

sanity check(s) when attempting to open owl file

Added by Derik Barseghian about 9 years ago. Updated about 9 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
tagging
Target version:
Start date:
09/16/2010
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
5184

Description

Intermittently on startup I get an error dialog, where tagging (or something) attempts to open an ontology file from a path that doesn't make sense -- it's basically two paths stuck together.

History

#1 Updated by Derik Barseghian about 9 years ago

As requested, stack trace:

[run] Ran additional initialization for module reporting from class org.kepler.module.reporting.Initialize
[run] Kepler Initializing...
[run] getAllRspnsElement is null
[run] org.semanticweb.owl.io.OWLOntologyCreationIOException: /Users/derik/dev2/kepler.modules.2.1/common-2.1/configs/ptolemy/configs/kepler/ontologies/Users/derik/KeplerData/modules/core/onto7934053400911427464.owl (No such file or directory)
[run] at uk.ac.manchester.cs.owl.ParsableOWLOntologyFactory.loadOWLOntology(ParsableOWLOntologyFactory.java:166)
[run] at uk.ac.manchester.cs.owl.OWLOntologyManagerImpl.loadOntology(OWLOntologyManagerImpl.java:380)
[run] at uk.ac.manchester.cs.owl.OWLOntologyManagerImpl.loadOntologyFromPhysicalURI(OWLOntologyManagerImpl.java:349)
[run] at org.kepler.sms.NamedOntModel.initialize(NamedOntModel.java:190)
[run] at org.kepler.sms.OntologyCatalog.initialize(OntologyCatalog.java:475)
[run] at org.kepler.sms.OntologyCatalog.initialize(OntologyCatalog.java:450)
[run] at org.kepler.sms.OntologyCatalog.<init>(OntologyCatalog.java:101)
[run] at org.kepler.sms.OntologyCatalog.instance(OntologyCatalog.java:119)
[run] at org.kepler.objectmanager.library.LibIndex.assureOntologyComponent(LibIndex.java:627)
[run] at org.kepler.objectmanager.library.LibIndex.rebuild(LibIndex.java:261)
[run] at org.kepler.objectmanager.library.LibraryManager.buildLibrary(LibraryManager.java:343)
[run] at org.kepler.moml.KARLibraryBuilder.buildLibrary(KARLibraryBuilder.java:78)
[run] at ptolemy.actor.gui.UserActorLibrary.openLibrary(UserActorLibrary.java:202)
[run] at ptolemy.actor.gui.UserActorLibrary.openUserLibrary(UserActorLibrary.java:140)
[run] at ptolemy.vergil.VergilApplication._createDefaultConfiguration(VergilApplication.java:330)
[run] at ptolemy.vergil.VergilApplication._createEmptyConfiguration(VergilApplication.java:347)
[run] at ptolemy.actor.gui.ConfigurationApplication._parseArgs(ConfigurationApplication.java:1128)
[run] at ptolemy.vergil.VergilApplication._parseArgs(VergilApplication.java:477)
[run] at ptolemy.actor.gui.ConfigurationApplication.<init>(ConfigurationApplication.java:226)
[run] at ptolemy.actor.gui.MoMLApplication.<init>(MoMLApplication.java:81)
[run] at ptolemy.vergil.VergilApplication.<init>(VergilApplication.java:110)
[run] at ptolemy.vergil.VergilApplication$1.run(VergilApplication.java:219)
[run] at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:209)
[run] at java.awt.EventQueue.dispatchEvent(EventQueue.java:461)
[run] at java.awt.EventDispatchThread.pumpOneEventForHierarchy(EventDispatchThread.java:269)
[run] at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:190)
[run] at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:184)
[run] at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:176)
[run] at java.awt.EventDispatchThread.run(EventDispatchThread.java:110)
[run] Caused by: java.io.FileNotFoundException: /Users/derik/dev2/kepler.modules.2.1/common-2.1/configs/ptolemy/configs/kepler/ontologies/Users/derik/KeplerData/modules/core/onto7934053400911427464.owl (No such file or directory)
[run] at java.io.FileInputStream.open(Native Method)
[run] at java.io.FileInputStream.<init>(FileInputStream.java:106)
[run] at java.io.FileInputStream.<init>(FileInputStream.java:66)
[run] at sun.net.www.protocol.file.FileURLConnection.connect(FileURLConnection.java:70)
[run] at sun.net.www.protocol.file.FileURLConnection.getInputStream(FileURLConnection.java:161)
[run] at org.semanticweb.owl.io.AbstractOWLParser.getInputStream(AbstractOWLParser.java:105)
[run] at org.semanticweb.owl.io.AbstractOWLParser.getInputSource(AbstractOWLParser.java:128)
[run] at org.coode.owl.rdfxml.parser.RDFXMLParser.parse(RDFXMLParser.java:85)
[run] at uk.ac.manchester.cs.owl.ParsableOWLOntologyFactory.loadOWLOntology(ParsableOWLOntologyFactory.java:154)
[run] ... 28 more

#2 Updated by Sean Riddle about 9 years ago

This is fixed in r25854-8. Sanity checks are present now when saving and loading the ontology_catalog.xml file to ensure that it consists of valid data.

#3 Updated by Redmine Admin over 6 years ago

Original Bugzilla ID was 5184

Also available in: Atom PDF