Project

General

Profile

Bug #5188

closing workflow does not save the location change of popup display windows.

Added by jianwu jianwu almost 9 years ago. Updated almost 7 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
core
Target version:
Start date:
09/21/2010
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
5188

Description

To find the differences:
1) create a test workflow with display actors
2a) save the workflow as a kar
2b) save the workflow as a moml file
3) open the saved workflow
4) run workflow to have popup display windows
5) move display windows to another location
6) close the workflow, no popup window will show for overwrite confirmation
7) open the workflow again and run it

If the workflow is saved as a moml file, the new window location will be saved and show in the new execution. But it doesn't work for kar file saving.


Related issues

Blocked by Kepler - Bug #5149: kar file saving problems.New08/16/2010

History

#1 Updated by jianwu jianwu almost 9 years ago

In the newest Kepler menu setting http://mercury.nceas.ucsb.edu/kepler/pipermail/kepler-dev/2010-September/018920.html, moml file has to explicitly 'Export ..' to save in step 6 and an overwrite confirmation dialog will showup.

#2 Updated by Daniel Crawl about 7 years ago

I was able to reproduce this for both KAR and MoML files, and also in Ptolemy. The problem is that if you change a popup window location, and close the workflow, the new location is lost.

#3 Updated by Christopher Brooks about 7 years ago

In Ptolemy:
1) Create SDFDirector, Const->Display model
2) Run the model
3) Drag the Display Actor to a new location
4) Save the model and exit
5) Restart the model, hit run
6) The Display actor is in the new location

What does not work is at step 4 to do File-> Exit - the new location is not saved.

Again, I think this is by design.

To save the locations of the Placeables, do File -> Save.

I'll look into this further.

#4 Updated by Christopher Brooks about 7 years ago

I checked in a change that may have fixed this, further testing is needed.

#5 Updated by Christopher Brooks about 7 years ago

I believe this is fixed. I'm reassigning this to Daniel for him to test.

#6 Updated by Daniel Crawl almost 7 years ago

Thanks for fixing this, Christopher. I verified it's fixed for MoMLs and KARs.

#7 Updated by Christopher Brooks almost 7 years ago

I'm reopening this because I'm going to back out the change to
actor/gui/WindowPropertiesAttribute.java that was saving the location
of Display actors without prompting.

The problem is that if the user opens a model and moves the Display actor
and then closes it, they are prompted for saving.

If the user wants to save the location of the Display actors, then they
should explicitly save the model.

See also http://bugzilla.ecoinformatics.org/show_bug.cgi?id=5637

#8 Updated by Christopher Brooks almost 7 years ago

I'm closing this as a won't fix because the system works as designed.

I suppose this could be opened as a low-priority rfe.

#9 Updated by Redmine Admin over 6 years ago

Original Bugzilla ID was 5188

Also available in: Atom PDF