Project

General

Profile

Bug #5206

Importing or opening a sensor site doesn't open into the sensor site view

Added by Derik Barseghian over 8 years ago. Updated about 8 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
sensor-view
Target version:
Start date:
10/18/2010
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
5206

Description

Importing or opening a saved sensor site doesn't necessarily change your set of views to Sensor Site and Plot Designer, they often open into the Workflow Editor. Also, if you have a workflow open, an imported sensor site will be placed into this workflow; it should probably be a new window.


Related issues

Blocks Kepler - Bug #4744: load & save site layout to local kar fileResolved02/05/2010

History

#1 Updated by Daniel Crawl over 8 years ago

Importing a sensor site now creates a new window and uses the EV model type. It also appears to be correctly setting the EV model type in the saved KAR, but opening the KAR creates the workflow editor window. I think the problem is in ActorMetadataKAREntryHandler.open(): it assumes everything uses PtolemyEffigies.

#2 Updated by Daniel Crawl over 8 years ago

The remaining problem (opening KAR into workflow editor) is in 4744.

#3 Updated by Derik Barseghian about 8 years ago

changing bugs from REAP to Kepler product

#4 Updated by Redmine Admin about 6 years ago

Original Bugzilla ID was 5206

Also available in: Atom PDF