Project

General

Profile

Bug #5251

using File->Open MoML... always opens model into Sensor Site view

Added by Derik Barseghian over 8 years ago. Updated about 8 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
sensor-view
Target version:
Start date:
12/02/2010
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
5251

Description

If in the sensor-view suite I open a regular xml model, e.g. 00-StatisticalSummary.xml, using the File->Open MoML... menu item, the new window is in the the Sensor Site view, with filtered component tree.
It should just open into the Workflow view. This is on mac and linux at r26412.

History

#1 Updated by Sean Riddle about 8 years ago

Fixed in r26872.

Note: This is fixed with an override of the class org.kepler.kar.handlers.ActorMetadataKAREntryHandler from core.

An alternative approach would be to add another KAREntryHandler, but the problem is that the entities involved (normal workflows and sensor view workflows) are not distinguishable at the KAREntryHandler dispatch level.

#2 Updated by Derik Barseghian about 8 years ago

changing bugs from REAP to Kepler product

#3 Updated by Redmine Admin about 6 years ago

Original Bugzilla ID was 5251

Also available in: Atom PDF