Project

General

Profile

Bug #5280

missing command line execution for KAR files

Added by Daniel Crawl over 8 years ago. Updated almost 7 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
execution engine
Target version:
Start date:
01/26/2011
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
5280

Description

KAR files cannot be used with kepler.sh.

The workflow in a KAR cannot be run with any of the -gui/-nogui, -cache/-nocache combinations, except -nogui -cache. Even in this case, no dependency checking is done, which results in an error if using the wrong set of modules.

Additionally, the Kepler GUI cannot be started with a workflow opened:

kepler.sh workflow.kar


Related issues

Is duplicate of Kepler - Bug #5638: "Ok" behavior of Use Module Manager prompt doesn't do what it should when opening from Recent FilesResolved07/13/2012

History

#1 Updated by Daniel Crawl almost 7 years ago

I've added more support for KAR files on the command line. KARs can be run with and without the gui. A KAR's module dependencies are also checked. I added a -force option to ignore them and try executing the KAR.

There's no support for running KARs with -nocache. It would take a major Kepler redesign to use KARs without the cache.

I also created an effigy for KARs so they can be opened from the command line via "kepler.sh HelloWorld.kar". It also checks the dependencies. If this check fails and the user decides not to force the KAR open, then the KAR ends up being opened by TextEffigy, which shows garbage since KARs are binary. It'd be nice if either TextEffigy would only open text files, or KAREffigy had some way of stopping EffigyFactory from trying to open the KAR with other effigy factories.

To close this bug:

1. prevent TextEffigy from opening KARs
2. test opening/running KARs in a released environment. In this case, if the module dependencies are not met, the user can download the missing modules and restart.
3. update docs on website and elsewhere about new command line options for KARs

#3 Updated by Ilkay Altintas almost 7 years ago

Still need to update the docs and the user manual. Also the text effigy will be updated to not open binaries.

#4 Updated by Christopher Brooks almost 7 years ago

See http://stackoverflow.com/questions/620993/determining-binary-text-file-type
for ideas about how to detect binary files.

Or, just check for files ending in .jar, .zip, .tar, .gz, submit a separate bug
for a more robust version of TextEffigy and move on. :-)

#5 Updated by Daniel Crawl almost 7 years ago

I updated TextEffigy to not open files with binary extensions. I also updated ExpressionShellEffigy to not create a window when the input file is specified.

I updated the docs on the website for the new command-line options, but the user guide still needs to be updated - bug #5625.

#6 Updated by Redmine Admin about 6 years ago

Original Bugzilla ID was 5280

Also available in: Atom PDF