Project

General

Profile

Bug #5326

2.2rc2 - upgrade config file bug workaround moves KeplerData/modules to KeplerData/modules.old instead of just configuration file dirs

Added by Derik Barseghian over 8 years ago. Updated about 8 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
core
Target version:
Start date:
02/25/2011
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
5326

Description

The workflow-around for the configuration file bug is to move a user's existing KeplerData/modules to KeplerData/modules.old during the first launch of 2.2. However I think we should instead just do something along the lines of moving each module's configuration dir to a configuration.old. The issue is that more than just config files reside in KeplerData/modules. E.g. the coreDB and provenance databases.

History

#1 Updated by David Welker over 8 years ago

Users can just copy any databases they want to retain after an upgrade manually from modules.old to modules.

#2 Updated by Matt Jones over 8 years ago

Reopening for 2.2. When upgrading Kepler from 2.1 to 2.2rc3, I lost my provenance database, which seems to be related to this bug. Previous versions were able to upgrade/downgrade without losing the provenance db. As this bug seems like an easily-avoided side-effect of the configuration change, and therefore simple to fix (by not moving the whole directory in the first place, and rather just moving the configuration files), and because the provenance db is supposed to be permanent, it should be fixed for 2.2 and not leave users with missing data.

#3 Updated by David Welker about 8 years ago

This has been fixed. Closing.

#4 Updated by Redmine Admin over 6 years ago

Original Bugzilla ID was 5326

Also available in: Atom PDF