Project

General

Profile

Bug #5442

View->Automate Layout doesn't work in kepler-2.3 branch

Added by Derik Barseghian almost 8 years ago. Updated over 7 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
general
Target version:
Start date:
07/14/2011
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
5442

Description

A bunch of ptolemy jars aren't added to the classpath when using the kepler-2.3 branch. This causes at least one problem, View->Automate Layout doesn't work.

If you:
ant change-to Dsuite=kepler-2.3;
ant run;
Then use: View
>Automate Layout

You get an error:
[run] java.lang.Exception: Failed to invoke layout graph dialog class "ptolemy.vergil.basic.layout.KielerLayoutAction", which was read from the configuration.
[run] at ptolemy.vergil.basic.BasicGraphFrame.layoutGraph(BasicGraphFrame.java:1146)
[run] at ptolemy.vergil.actor.ActorGraphFrame$LayoutAction.actionPerformed(ActorGraphFrame.java:758)
[run] at javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:2028)
[run] at javax.swing.AbstractButton$Handler.actionPerformed(AbstractButton.java:2351)
[run] at javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:387)
[run] at javax.swing.DefaultButtonModel.setPressed(DefaultButtonModel.java:242)
[run] at javax.swing.AbstractButton.doClick(AbstractButton.java:389)
[run] at com.apple.laf.ScreenMenuItem.actionPerformed(ScreenMenuItem.java:95)
[run] at java.awt.MenuItem.processActionEvent(MenuItem.java:627)
[run] at java.awt.MenuItem.processEvent(MenuItem.java:586)
[run] at java.awt.MenuComponent.dispatchEventImpl(MenuComponent.java:337)
[run] at java.awt.MenuComponent.dispatchEvent(MenuComponent.java:325)
[run] at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:682)
[run] at java.awt.EventQueue.access$000(EventQueue.java:85)
[run] at java.awt.EventQueue$1.run(EventQueue.java:638)
[run] at java.awt.EventQueue$1.run(EventQueue.java:636)
[run] at java.security.AccessController.doPrivileged(Native Method)
[run] at java.security.AccessControlContext$1.doIntersectionPrivilege(AccessControlContext.java:87)
[run] at java.security.AccessControlContext$1.doIntersectionPrivilege(AccessControlContext.java:98)
[run] at java.awt.EventQueue$2.run(EventQueue.java:652)
[run] at java.awt.EventQueue$2.run(EventQueue.java:650)
[run] at java.security.AccessController.doPrivileged(Native Method)
[run] at java.security.AccessControlContext$1.doIntersectionPrivilege(AccessControlContext.java:87)
[run] at java.awt.EventQueue.dispatchEvent(EventQueue.java:649)
[run] at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:296)
[run] at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:211)
[run] at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:201)
[run] at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:196)
[run] at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:188)
[run] at java.awt.EventDispatchThread.run(EventDispatchThread.java:122)
[run] Caused by: java.lang.NoClassDefFoundError: de/cau/cs/kieler/core/KielerException
[run] at ptolemy.vergil.basic.layout.KielerLayoutAction.doAction(KielerLayoutAction.java:139)
[run] at ptolemy.vergil.basic.BasicGraphFrame.layoutGraph(BasicGraphFrame.java:1141)
[run] ... 29 more
[run] Caused by: java.lang.ClassNotFoundException: de.cau.cs.kieler.core.KielerException
[run] at java.net.URLClassLoader$1.run(URLClassLoader.java:202)
[run] at java.security.AccessController.doPrivileged(Native Method)
[run] at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
[run] at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
[run] at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301)
[run] at java.lang.ClassLoader.loadClass(ClassLoader.java:247)
[run] ... 31 more

If you edit your kepler-2.3/module-info/modules.txt to refer to ptolemy instead of ptolemy-kepler-2.3 (either rename your ptolemy-kepler-2.3 to ptolemy, or just use your existing 'trunk' ptolemy dir), and restart kepler-2.3, Automate Layout works fine.

I compared the classpaths between the two ways of launching kepler described above, and when using "ptolemy-kepler-2.3", the classpath is lacking a bunch of jars, including the kieler.jar:

/Users/derik/dev2/kepler.modules/ptolemy/src/lib/PDFRenderer.jar:/Users/derik/dev2/kepler.modules/ptolemy/src/lib/aopalliance-license.htm:/Users/derik/dev2/kepler.modules/ptolemy/src/lib/aopalliance.jar:/Users/derik/dev2/kepler.modules/ptolemy/src/lib/bsh-2.0b4.jar:/Users/derik/dev2/kepler.modules/ptolemy/src/lib/chic.jar:/Users/derik/dev2/kepler.modules/ptolemy/src/lib/diva.jar:/Users/derik/dev2/kepler.modules/ptolemy/src/lib/guice-3.0.jar:/Users/derik/dev2/kepler.modules/ptolemy/src/lib/guice-license.htm:/Users/derik/dev2/kepler.modules/ptolemy/src/lib/jasminclasses.jar:/Users/derik/dev2/kepler.modules/ptolemy/src/lib/java_cup.jar:/Users/derik/dev2/kepler.modules/ptolemy/src/lib/javax.inject-license.htm:/Users/derik/dev2/kepler.modules/ptolemy/src/lib/javax.inject.jar:/Users/derik/dev2/kepler.modules/ptolemy/src/lib/jna.jar:/Users/derik/dev2/kepler.modules/ptolemy/src/lib/junit-4.8.2.jar:/Users/derik/dev2/kepler.modules/ptolemy/src/lib/junit-license.htm:/Users/derik/dev2/kepler.modules/ptolemy/src/lib/jython.jar:/Users/derik/dev2/kepler.modules/ptolemy/src/lib/kieler.jar:/Users/derik/dev2/kepler.modules/ptolemy/src/lib/libptmatlab.jnilib:/Users/derik/dev2/kepler.modules/ptolemy/src/lib/libptmatlab.so:/Users/derik/dev2/kepler.modules/ptolemy/src/lib/mapss.jar:/Users/derik/dev2/kepler.modules/ptolemy/src/lib/matlab.jar:/Users/derik/dev2/kepler.modules/ptolemy/src/lib/matlabLinux.jar:/Users/derik/dev2/kepler.modules/ptolemy/src/lib/matlabMacOSX.jar:/Users/derik/dev2/kepler.modules/ptolemy/src/lib/matlabSunOS.jar:/Users/derik/dev2/kepler.modules/ptolemy/src/lib/matlabWindows.jar:/Users/derik/dev2/kepler.modules/ptolemy/src/lib/naomi.jar:/Users/derik/dev2/kepler.modules/ptolemy/src/lib/ojdcheck-license.htm:/Users/derik/dev2/kepler.modules/ptolemy/src/lib/ojdcheck.jar:/Users/derik/dev2/kepler.modules/ptolemy/src/lib/polyglotclasses-1.3.2.jar:/Users/derik/dev2/kepler.modules/ptolemy/src/lib/ptCal.jar:/Users/derik/dev2/kepler.modules/ptolemy/src/lib/ptII.properties.in:/Users/derik/dev2/kepler.modules/ptolemy/src/lib/ptcolt.jar:/Users/derik/dev2/kepler.modules/ptolemy/src/lib/ptjacl.jar:/Users/derik/dev2/kepler.modules/ptolemy/src/lib/rxtxMacOSX.jar:/Users/derik/dev2/kepler.modules/ptolemy/src/lib/rxtxWindows.jar:/Users/derik/dev2/kepler.modules/ptolemy/src/lib/saxon8-dom.jar:/Users/derik/dev2/kepler.modules/ptolemy/src/lib/saxon8.jar:/Users/derik/dev2/kepler.modules/ptolemy/src/lib/sootclasses.jar:/Users/derik/dev2/kepler.modules/ptolemy/src/lib/swing-worker-1.2.jar:/Users/derik/dev2/kepler.modules/ptolemy/src/lib/swing-worker-license.htm

History

#1 Updated by Derik Barseghian almost 8 years ago

Fixed by 27944-27947 for 2.3.

But not yet fixed for 2.3.0 test release.

#2 Updated by Derik Barseghian almost 8 years ago

fixed the 2.3.0 issue at r27961

#3 Updated by Derik Barseghian over 7 years ago

Note these changes need change at r27949.

(In reply to comment #1)

Fixed by 27944-27947 for 2.3.

But not yet fixed for 2.3.0 test release.

#4 Updated by Redmine Admin about 6 years ago

Original Bugzilla ID was 5442

Also available in: Atom PDF