Project

General

Profile

Bug #5485

standalone Module Manager can break Kepler app ability to startup

Added by Derik Barseghian about 8 years ago. Updated about 7 years ago.

Status:
Resolved
Priority:
Normal
Category:
module manager
Target version:
Start date:
09/08/2011
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
5485

Description

Sometimes the standalone Module Manager copies its module-manager-gui/module-info/modules.txt over the modules.txt that kepler uses. If you then simply quit Module Manager without choosing a suite, the Kepler app will fail to launch.

History

#1 Updated by Ilkay Altintas over 7 years ago

Not able to reproduce this. Will try more and close it if not reproducible.

#2 Updated by Daniel Crawl over 7 years ago

I'm unable to reproduce.

#3 Updated by Daniel Crawl about 7 years ago

Jianwu and I figured out how to reproduce this problem:

1. start Kepler, run Module Manager, change to 2.3 suite
This downloads the 2.3 modules into KeplerData/kepler.modules if they are not already there.
2. cd to build-area for svn trunk
3. ant make-startup-scripts
4. cd ..
5. ./module-manager.sh
This starts the Module Manager as a standalone application and in the process changes build-area/{current-suite,modules}.txt to be the Module Manager suite described in build-area/module-manager-gui.txt. When the Module Manager quits, the suite is left as Module Manager, so Kepler cannot start.

#4 Updated by Daniel Crawl about 7 years ago

I updated the Module Manager to look at the selected suite before it exits. If it doesn't look like Kepler will start with this suite, an error dialog pops up. Reassigning to Derik to test.

#5 Updated by jianwu jianwu about 7 years ago

Hi Derik,

Did you test Dan's update? Please update its status. Thanks.

#6 Updated by Derik Barseghian about 7 years ago

Yep, I tested this awhile ago and Dan's new warning message seems good.

#7 Updated by Redmine Admin over 6 years ago

Original Bugzilla ID was 5485

Also available in: Atom PDF