Project

General

Profile

Bug #5550

Windows installer should be a .exe, not a .jar

Added by Christopher Brooks about 7 years ago. Updated over 6 years ago.

Status:
Resolved
Priority:
Normal
Category:
installer
Target version:
Start date:
11/22/2011
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
5550

Description

Downloading and running a .jar file under Windows Server 2008 is tricky.
Basically, the user needs to run a command from a command line, which can be
tricky if there are spaces or parentheses in the file name.

There have been questions about starting the jar file.

https://kepler-project.org/users/faq#under-windows-when-i says:

--start--
Under Windows, when I double click on the installer jar file, the installer does not start. What do I do?

Under Windows, the Kepler installer jar file should start the Kepler installer using Java, it should not unzip.
If it unzips, then see http://www.wikihow.com/Run-a-.Jar-Java-File

or

http://stackoverflow.com/questions/394616/running-jar-file-in-windows
--end--

Rather than shipping a .jar file, we should ship a .exe for the installer.
One way would be to use Launch4J, see http://launch4j.sourceforge.net/

History

#1 Updated by jianwu jianwu over 6 years ago

It would be great if the 'make-windows-installer' ant task for kepler can automatically utilize Launch4J to create exe installer.

Since its priority is low, I suggest we do it for 2.5 or 3.0.

#2 Updated by Christopher Brooks over 6 years ago

I'm moving this back to 2.4.0 and assigning it to myself.

The problem is that clicking on a .jar file does not reliably work, we
get email about this, see the FAQ.

Kepler needs to work well on Windows.

#3 Updated by Christopher Brooks over 6 years ago

ant make-windows-installer -Dversion=2.3.4-rc666
now builds a .exe installer instead of a .jar installer.

I ran the ant command under Mac OS X and Linux.

We are using Launch4j from
http://launch4j.sourceforge.net/

I had to add some subdirectories to build-area/lib for launch4j
I also had to add platform-dependent binaries to
build-area/resources/installer/launch4j

#4 Updated by Redmine Admin over 5 years ago

Original Bugzilla ID was 5550

Also available in: Atom PDF