Project

General

Profile

Bug #5726

actor names ending in digit renamed on canvas

Added by Daniel Crawl almost 7 years ago. Updated over 6 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
general
Target version:
Start date:
10/30/2012
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
5726

Description

There are several actors in the biokepler suite with names ending in digits: yn00, run-mummer1, primer3. When they are added to the canvas, the digit is removed from the name. To fix this, the numbers should not be removed. If there is already an actor with the same name, then a suffix like _2, _3, etc., could be used.

History

#2 Updated by Daniel Crawl almost 7 years ago

Christopher wrote:

Is this a duplicate of bug #4049 at
http://bugzilla.ecoinformatics.org/show_bug.cgi?id=4049
See also
https://chess.eecs.berkeley.edu/bugzilla/show_bug.cgi?id=61

The fix for https://chess.eecs.berkeley.edu/bugzilla/show_bug.cgi?id=61 was to not remove the trailing underscores. However, trailing digits are removed. Why this is done? It's not required to generate a unique name.

This is a duplicate of bug #4049 comments 4 and 5, but not 1-3.

#3 Updated by Redmine Admin over 6 years ago

Original Bugzilla ID was 5726

#4 Updated by Daniel Crawl over 6 years ago

  • Status changed from New to Resolved

I found that if the display name is set and the display name is different from the name, then the ending digits are not removed when the actor is placed on the canvas. For all the biokepler actors whose names end in a digit, I set the display name and made the name different by appending a space.

Also available in: Atom PDF