Project

General

Profile

Bug #6572

An error is thrown when opening MatlabExpression.xml in common/workflows/demos/Matlab in trunk.

Added by jianwu jianwu almost 5 years ago. Updated about 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
actors
Target version:
Start date:
06/16/2014
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:

Description

I got the following errors. The main reason is that $name is in the documentation of the actor explaining the expression parameter. If I edit the xml changing from $name to be $$name, the workflow can be opened correctly.

The same workflow works fine with Kepler 2.4. Not sure which changes in Kepler trunk cause this problem.

ptolemy.kernel.util.IllegalActionException: Error evaluating expression:
The parameter that is evaluated to produce the output. Typically, this parameter
evaluates an expression involving the inputs. To refer to parameters in scope
within the expression, use $name or ${name}, where "name" is the name of the
parameter.

in .MatlabExpression.MatlabExpression.<Unnamed Object>.expression (parameter)
Because:
The ID name is undefined.
in .MatlabExpression.MatlabExpression.<Unnamed Object>.expression (parameter)
Because:
Error evaluating expression:
The parameter that is evaluated to produce the output. Typically, this parameter
evaluates an expression involving the inputs. To refer to parameters in scope
within the expression, use $name or ${name}, where "name" is the name of the
parameter.
in .MatlabExpression.MatlabExpression.<Unnamed Object>.expression (parameter)
Because:
The ID name is undefined.
at ptolemy.data.expr.Variable.validate(Variable.java:1507)
at ptolemy.moml.MoMLParser.endDocument(MoMLParser.java:816)
at com.microstar.xml.XmlParser.doParse(XmlParser.java:162)
at com.microstar.xml.XmlParser.parse(XmlParser.java:132)
at ptolemy.moml.MoMLParser.parse(MoMLParser.java:1571)
at ptolemy.moml.MoMLParser.parse(MoMLParser.java:1507)
at ptolemy.moml.MoMLParser.parse(MoMLParser.java:1451)
at ptolemy.moml.MoMLParser.parseFile(MoMLParser.java:1735)
at org.kepler.gui.component.OpenCompositeAction.actionPerformed(OpenCompositeAction.java:147)
at javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:2028)
at javax.swing.AbstractButton$Handler.actionPerformed(AbstractButton.java:2351)
at javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:387)
at javax.swing.DefaultButtonModel.setPressed(DefaultButtonModel.java:242)
at javax.swing.AbstractButton.doClick(AbstractButton.java:389)
at javax.swing.plaf.basic.BasicMenuItemUI.doClick(BasicMenuItemUI.java:809)
at com.apple.laf.AquaMenuItemUI.doClick(AquaMenuItemUI.java:137)
at javax.swing.plaf.basic.BasicMenuItemUI$Handler.mouseReleased(BasicMenuItemUI.java:850)
at java.awt.Component.processMouseEvent(Component.java:6414)
at javax.swing.JComponent.processMouseEvent(JComponent.java:3275)
at java.awt.Component.processEvent(Component.java:6179)
at java.awt.Container.processEvent(Container.java:2084)
at java.awt.Component.dispatchEventImpl(Component.java:4776)
at java.awt.Container.dispatchEventImpl(Container.java:2142)
at java.awt.Component.dispatchEvent(Component.java:4604)
at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4618)
at java.awt.LightweightDispatcher.processMouseEvent(Container.java:4279)
at java.awt.LightweightDispatcher.dispatchEvent(Container.java:4209)
at java.awt.Container.dispatchEventImpl(Container.java:2128)
at java.awt.Window.dispatchEventImpl(Window.java:2492)
at java.awt.Component.dispatchEvent(Component.java:4604)
at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:717)
at java.awt.EventQueue.access$400(EventQueue.java:82)
at java.awt.EventQueue$2.run(EventQueue.java:676)
at java.awt.EventQueue$2.run(EventQueue.java:674)
at java.security.AccessController.doPrivileged(Native Method)
at java.security.AccessControlContext$1.doIntersectionPrivilege(AccessControlContext.java:86)
at java.security.AccessControlContext$1.doIntersectionPrivilege(AccessControlContext.java:97)
at java.awt.EventQueue$3.run(EventQueue.java:690)
at java.awt.EventQueue$3.run(EventQueue.java:688)
at java.security.AccessController.doPrivileged(Native Method)
at java.security.AccessControlContext$1.doIntersectionPrivilege(AccessControlContext.java:86)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:687)
at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:296)
at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:211)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:201)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:196)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:188)
at java.awt.EventDispatchThread.run(EventDispatchThread.java:122)
Caused by: ptolemy.kernel.util.IllegalActionException: Error evaluating expression:
The parameter that is evaluated to produce the output. Typically, this parameter
evaluates an expression involving the inputs. To refer to parameters in scope
within the expression, use $name or ${name}, where "name" is the name of the
parameter.
in .MatlabExpression.MatlabExpression.<Unnamed Object>.expression (parameter)
Because:
The ID name is undefined.
at ptolemy.data.expr.Variable._evaluate(Variable.java:1771)
at ptolemy.data.expr.Variable._propagate(Variable.java:1848)
at ptolemy.data.expr.Variable.validate(Variable.java:1484)
... 47 more
Caused by: ptolemy.data.expr.UndefinedConstantOrIdentifierException: The ID name is undefined.
at ptolemy.data.expr.ParseTreeEvaluator.visitLeafNode(ParseTreeEvaluator.java:723)
at ptolemy.data.expr.ASTPtLeafNode.visit(ASTPtLeafNode.java:125)
at ptolemy.data.expr.ParseTreeEvaluator._evaluateChild(ParseTreeEvaluator.java:1360)
at ptolemy.data.expr.ParseTreeEvaluator._evaluateAllChildren(ParseTreeEvaluator.java:1314)
at ptolemy.data.expr.ParseTreeEvaluator.visitSumNode(ParseTreeEvaluator.java:1166)
at ptolemy.data.expr.ASTPtSumNode.visit(ASTPtSumNode.java:129)
at ptolemy.data.expr.ParseTreeEvaluator.evaluateParseTree(ParseTreeEvaluator.java:105)
at ptolemy.data.expr.Variable._evaluate(Variable.java:1753)
... 49 more
Caused by: ptolemy.kernel.util.IllegalActionException: Error evaluating expression:
The parameter that is evaluated to produce the output. Typically, this parameter
evaluates an expression involving the inputs. To refer to parameters in scope
within the expression, use $name or ${name}, where "name" is the name of the
parameter.
in .MatlabExpression.MatlabExpression.<Unnamed Object>.expression (parameter)
Because:
The ID name is undefined.
at ptolemy.data.expr.Variable._evaluate(Variable.java:1771)
at ptolemy.data.expr.Variable._propagate(Variable.java:1848)
at ptolemy.data.expr.Variable.validate(Variable.java:1484)
at ptolemy.moml.MoMLParser.endDocument(MoMLParser.java:816)
at com.microstar.xml.XmlParser.doParse(XmlParser.java:162)
at com.microstar.xml.XmlParser.parse(XmlParser.java:132)
at ptolemy.moml.MoMLParser.parse(MoMLParser.java:1571)
at ptolemy.moml.MoMLParser.parse(MoMLParser.java:1507)
at ptolemy.moml.MoMLParser.parse(MoMLParser.java:1451)
at ptolemy.moml.MoMLParser.parseFile(MoMLParser.java:1735)
at org.kepler.gui.component.OpenCompositeAction.actionPerformed(OpenCompositeAction.java:147)
at javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:2028)
at javax.swing.AbstractButton$Handler.actionPerformed(AbstractButton.java:2351)
at javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:387)
at javax.swing.DefaultButtonModel.setPressed(DefaultButtonModel.java:242)
at javax.swing.AbstractButton.doClick(AbstractButton.java:389)
at javax.swing.plaf.basic.BasicMenuItemUI.doClick(BasicMenuItemUI.java:809)
at com.apple.laf.AquaMenuItemUI.doClick(AquaMenuItemUI.java:137)
at javax.swing.plaf.basic.BasicMenuItemUI$Handler.mouseReleased(BasicMenuItemUI.java:850)
at java.awt.Component.processMouseEvent(Component.java:6414)
at javax.swing.JComponent.processMouseEvent(JComponent.java:3275)
at java.awt.Component.processEvent(Component.java:6179)
at java.awt.Container.processEvent(Container.java:2084)
at java.awt.Component.dispatchEventImpl(Component.java:4776)
at java.awt.Container.dispatchEventImpl(Container.java:2142)
at java.awt.Component.dispatchEvent(Component.java:4604)
at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4618)
at java.awt.LightweightDispatcher.processMouseEvent(Container.java:4279)
at java.awt.LightweightDispatcher.dispatchEvent(Container.java:4209)
at java.awt.Container.dispatchEventImpl(Container.java:2128)
at java.awt.Window.dispatchEventImpl(Window.java:2492)
at java.awt.Component.dispatchEvent(Component.java:4604)
at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:717)
at java.awt.EventQueue.access$400(EventQueue.java:82)
at java.awt.EventQueue$2.run(EventQueue.java:676)
at java.awt.EventQueue$2.run(EventQueue.java:674)
at java.security.AccessController.doPrivileged(Native Method)
at java.security.AccessControlContext$1.doIntersectionPrivilege(AccessControlContext.java:86)
at java.security.AccessControlContext$1.doIntersectionPrivilege(AccessControlContext.java:97)
at java.awt.EventQueue$3.run(EventQueue.java:690)
at java.awt.EventQueue$3.run(EventQueue.java:688)
at java.security.AccessController.doPrivileged(Native Method)
at java.security.AccessControlContext$1.doIntersectionPrivilege(AccessControlContext.java:86)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:687)
at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:296)
at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:211)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:201)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:196)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:188)
at java.awt.EventDispatchThread.run(EventDispatchThread.java:122)
Caused by: ptolemy.data.expr.UndefinedConstantOrIdentifierException: The ID name is undefined.
at ptolemy.data.expr.ParseTreeEvaluator.visitLeafNode(ParseTreeEvaluator.java:723)
at ptolemy.data.expr.ASTPtLeafNode.visit(ASTPtLeafNode.java:125)
at ptolemy.data.expr.ParseTreeEvaluator._evaluateChild(ParseTreeEvaluator.java:1360)
at ptolemy.data.expr.ParseTreeEvaluator._evaluateAllChildren(ParseTreeEvaluator.java:1314)
at ptolemy.data.expr.ParseTreeEvaluator.visitSumNode(ParseTreeEvaluator.java:1166)
at ptolemy.data.expr.ASTPtSumNode.visit(ASTPtSumNode.java:129)
at ptolemy.data.expr.ParseTreeEvaluator.evaluateParseTree(ParseTreeEvaluator.java:105)
at ptolemy.data.expr.Variable._evaluate(Variable.java:1753)
... 49 more
Caused by: ptolemy.data.expr.UndefinedConstantOrIdentifierException: The ID name is undefined.
at ptolemy.data.expr.ParseTreeEvaluator.visitLeafNode(ParseTreeEvaluator.java:723)
at ptolemy.data.expr.ASTPtLeafNode.visit(ASTPtLeafNode.java:125)
at ptolemy.data.expr.ParseTreeEvaluator._evaluateChild(ParseTreeEvaluator.java:1360)
at ptolemy.data.expr.ParseTreeEvaluator._evaluateAllChildren(ParseTreeEvaluator.java:1314)
at ptolemy.data.expr.ParseTreeEvaluator.visitSumNode(ParseTreeEvaluator.java:1166)
at ptolemy.data.expr.ASTPtSumNode.visit(ASTPtSumNode.java:129)
at ptolemy.data.expr.ParseTreeEvaluator.evaluateParseTree(ParseTreeEvaluator.java:105)
at ptolemy.data.expr.Variable._evaluate(Variable.java:1753)
at ptolemy.data.expr.Variable._propagate(Variable.java:1848)
at ptolemy.data.expr.Variable.validate(Variable.java:1484)
at ptolemy.moml.MoMLParser.endDocument(MoMLParser.java:816)
at com.microstar.xml.XmlParser.doParse(XmlParser.java:162)
at com.microstar.xml.XmlParser.parse(XmlParser.java:132)
at ptolemy.moml.MoMLParser.parse(MoMLParser.java:1571)
at ptolemy.moml.MoMLParser.parse(MoMLParser.java:1507)
at ptolemy.moml.MoMLParser.parse(MoMLParser.java:1451)
at ptolemy.moml.MoMLParser.parseFile(MoMLParser.java:1735)
at org.kepler.gui.component.OpenCompositeAction.actionPerformed(OpenCompositeAction.java:147)
at javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:2028)
at javax.swing.AbstractButton$Handler.actionPerformed(AbstractButton.java:2351)
at javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:387)
at javax.swing.DefaultButtonModel.setPressed(DefaultButtonModel.java:242)
at javax.swing.AbstractButton.doClick(AbstractButton.java:389)
at javax.swing.plaf.basic.BasicMenuItemUI.doClick(BasicMenuItemUI.java:809)
at com.apple.laf.AquaMenuItemUI.doClick(AquaMenuItemUI.java:137)
at javax.swing.plaf.basic.BasicMenuItemUI$Handler.mouseReleased(BasicMenuItemUI.java:850)
at java.awt.Component.processMouseEvent(Component.java:6414)
at javax.swing.JComponent.processMouseEvent(JComponent.java:3275)
at java.awt.Component.processEvent(Component.java:6179)
at java.awt.Container.processEvent(Container.java:2084)
at java.awt.Component.dispatchEventImpl(Component.java:4776)
at java.awt.Container.dispatchEventImpl(Container.java:2142)
at java.awt.Component.dispatchEvent(Component.java:4604)
at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4618)
at java.awt.LightweightDispatcher.processMouseEvent(Container.java:4279)
at java.awt.LightweightDispatcher.dispatchEvent(Container.java:4209)
at java.awt.Container.dispatchEventImpl(Container.java:2128)
at java.awt.Window.dispatchEventImpl(Window.java:2492)
at java.awt.Component.dispatchEvent(Component.java:4604)
at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:717)
at java.awt.EventQueue.access$400(EventQueue.java:82)
at java.awt.EventQueue$2.run(EventQueue.java:676)
at java.awt.EventQueue$2.run(EventQueue.java:674)
at java.security.AccessController.doPrivileged(Native Method)
at java.security.AccessControlContext$1.doIntersectionPrivilege(AccessControlContext.java:86)
at java.security.AccessControlContext$1.doIntersectionPrivilege(AccessControlContext.java:97)
at java.awt.EventQueue$3.run(EventQueue.java:690)
at java.awt.EventQueue$3.run(EventQueue.java:688)
at java.security.AccessController.doPrivileged(Native Method)
at java.security.AccessControlContext$1.doIntersectionPrivilege(AccessControlContext.java:86)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:687)
at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:296)
at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:211)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:201)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:196)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:188)
at java.awt.EventDispatchThread.run(EventDispatchThread.java:122)

History

#1 Updated by Daniel Crawl about 4 years ago

  • Status changed from New to Resolved

I've fixed MatlabExpression.xml in svn. If you still get this error when opening the workflow from the demos folder in the actor library, then you'll need to remove $HOME/KeplerData/workflows/module/outreach/demos/Matlab/MatlabExpression.xml.

Also available in: Atom PDF