Project

General

Profile

Bug #6955

Error when submitting to registry

Added by Lauren Walker almost 4 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Normal
Category:
registry
Target version:
Start date:
01/28/2016
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:

Description

I get the following error when trying to submit metadata to the dev.nceas registry: The docid is not valid since it is null or contians the white space(s).

Attached is a screenshot of the simple metadata I provided.

History

#1 Updated by ben leinfelder almost 4 years ago

  • Target version set to 2.6.0

I updated the permissions on the /var/metacat/temporary directory where the registry writes some necessary temporary files during upload. This resolved the blank docid issue.

But others continue to report that there is a schema validation error when submitting the form. It seems to be intermittent in that I was able to successfully upload a metadata record without encountering the error, but Lauren (and Julien and Greg) were not able to.

cvc-complex-type.2.4.a: Invalid content was found starting with element 'metadataProvider'. 
One of '{associatedParty, pubDate, language, series, abstract, keywordSet, additionalInfo, intellectualRights, distribution, coverage, purpose, maintenance, contact}' is expected.

The registry seems to incorrectly order the metadataProvider and associatedParty elements. The metadataProvider element should come before any associated party elements, but in Lauren's case it was placed after. She reports that on a subsequent test, she was able to upload a record so it is not consistent.

#2 Updated by ben leinfelder over 3 years ago

  • Status changed from New to Closed

Chris has substantially re-worked the party handling and I believe this can be closed.

Also available in: Atom PDF