Project

General

Profile

Bug #696

Implement reference and party-related database changes

Added by Michael Lee almost 20 years ago. Updated about 16 years ago.

Status:
Resolved
Priority:
Immediate
Category:
misc
Target version:
Start date:
11/13/2002
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
696

Description

JH completes.

NewRefPkg_Three.xml (46.1 KB) NewRefPkg_Three.xml Michael Lee, 01/07/2003 10:09 AM
NewRef_3.sql (15.6 KB) NewRef_3.sql Michael Lee, 01/07/2003 11:56 AM
NewRefPkg_Three.xml (49.6 KB) NewRefPkg_Three.xml Michael Lee, 01/07/2003 11:59 AM
NewRefSchema_citationOnly.vsd (137 KB) NewRefSchema_citationOnly.vsd Michael Lee, 01/07/2003 12:03 PM
NewRefImpl.zip (71.4 KB) NewRefImpl.zip Michael Lee, 01/15/2003 10:19 AM
NewCitationERD.jpg (64.8 KB) NewCitationERD.jpg Michael Lee, 01/15/2003 10:26 AM

Related issues

Is duplicate of VegBank - Bug #799: Implement new Citation datamodel - VegBank (Farrell) and VegBranch (Lee)Resolved11/13/2002

Blocks VegBank - Bug #697: [293] Revision and review of data model for References-bResolved11/13/2002

Blocked by VegBank - Bug #703: Enter 1996 & 2002 USDA Plants ListResolved11/13/2002

History

#1 Updated by Michael Lee almost 20 years ago

This is the third step of a 3 part bug. First PI's need to refine the data
model for references and citations. Then, MTL will implement as possible and
then this bug can be finished.

#2 Updated by Michael Lee almost 20 years ago

The revision mentioned by the PI's will not be ready until circa Dec 9, after a
meeting in D.C. with similar organizations.

#3 Updated by Michael Lee over 19 years ago

This is an XML document that shows the structure of the new references data
format that will be added to the plots, comm, and plants modules.

#4 Updated by Michael Lee over 19 years ago

This is a SQL statement that creates the new reference tables for all 3
modules. It also creates the appropriate relationships. It adds auxillary
tables for the closed lists that are associated with these tables and inserts
the lists values.

Currently, alternateIdentifier is orphaned; I assume we need to add a FK into
the citation (reference) table that would link to alternateIdentifier.

#5 Updated by Michael Lee over 19 years ago

added nulls attribute to each field, which was necessary for generating SQL.
These could change - this is just a first cut at which fields should be
required.

#6 Updated by Michael Lee over 19 years ago

This is a Visio diagram that shows the relationship of the citation tables that
represent the new reference model. AlternateIdentifier is orphaned, which
needs a solution.

#7 Updated by John Harris over 19 years ago

Due to:
1] Gabe starting work on the vegbank codebase and the desire to have him work
with 'working' code
2] the extensiveness of these changes
this bug is set to 1.0.0beta2

#8 Updated by Michael Lee over 19 years ago

To download, save as a .zip (or rename once saved), then extract. This is only
the references model, not the rest of the db. Again, alternateIdentifier is
orphaned and that needs to be addressed, as I doubt this is correct.

#10 Updated by Robert Peet over 19 years ago

Notes on the ACCESS version of the reference model

For all fields in my email of 12 Dec where I had an *, grab the definition
from
http://knb.ecoinformatics.org/software/eml/eml-2.0.0/eml-literature.html
and embed it in the definition field in the ACCESS database.

1. aux_citation_citationType. Why SortOrd? Not sure what this ordering is
about.

2. Table: aux_citation_titleSuperior. You missed the point here.
Citation:titleSuperior is not a constrained list, but contains a second,
higher order title where appropriate, which in the case of a chapter is a Book
title, and in the case of a Conference Presentation is the Name of the
Conference.

3. aux_citationContributor_roleType. Why SortOrd? Not sure what this ordering
is about.

4. Citation:communicationType. This will be an open list, probably maintained
in aux_communicationType. Examples include memo, letter, email

5. CitationAlternateIdentifier needs to have a field that is a FK back to
citation.

6. Aux_CitationAlternateIdentifier_system is missing. This is aa open list.
This could be any identifier system. The EML definition is “An additional,
secondary identifier for this entity. The primary identifier belongs in
the "id" attribute, but additional identifiers that are used to label this
entity, possibly from different data management systems, can be listed here.”

#11 Updated by Gabriel Farrell over 19 years ago

This work is complete.

Caveats:

The forms for filling in references need to be updated to capture the new data.
e.g. We have a field called authors that must be replaced with many fields.

The vegbranch plots loader doesn't do references, i.e. has never done them.

#12 Updated by Gabriel Farrell over 19 years ago

  • Bug 799 has been marked as a duplicate of this bug. ***

#13 Updated by Michael Lee over 17 years ago

changed from components that are to be deleted to "misc" so that bugs don't get
deleted with component. Sorry for all the email.

#14 Updated by Redmine Admin over 9 years ago

Original Bugzilla ID was 696

Also available in: Atom PDF