Project

General

Profile

Bug #703

Enter 1996 & 2002 USDA Plants List

Added by Michael Lee almost 20 years ago. Updated over 17 years ago.

Status:
Resolved
Priority:
Normal
Category:
misc
Target version:
Start date:
11/13/2002
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
703

Description

Need to test. Would help if JH were again to provide an Access style dump of
some or all of the data.


Related issues

Blocks VegBank - Bug #685: Redesign plant taxonomy data modelResolved11/13/2002

Blocks VegBank - Bug #696: Implement reference and party-related database changesResolved11/13/2002

Blocks VegBank - Bug #700: Implement redesigned plant taxonomy data modelResolved11/13/2002

History

#1 Updated by John Harris over 19 years ago

After the taxonomy databases have been modified to include the new references
and name systems and are built and the code works the 1996 & 2002 USDA plant
data will have to be re-loaded

#2 Updated by Gabriel Farrell over 19 years ago

vegbank has had it current data migrated into the new data model.

We will need the confirm that the loader is correct on the test machine before
it is of value to load this onto vegbank.

#3 Updated by Gabriel Farrell over 19 years ago

Look at how plants are loaded on tekka or beta to confirm correctness

#4 Updated by Michael Lee over 19 years ago

this evaluation is captured in bug 702

  • This bug has been marked as a duplicate of 702 ***

#5 Updated by Michael Lee about 19 years ago

Families need to be loaded with loader as well. Lee has fixed the current
VegBAnk plants by loading families manually and updating genera to having
families as parents. The loader needs to be updated to do this as USDA plants
are loaded.

Families should be loaded based on the family name (ie Poaceae), with status of
"accepted" and a usage of the same family name (Poaceae) as "scientific without
Authors" name system.

#6 Updated by Gabriel Farrell about 19 years ago

Plants are now loaded according to comment #5 .
Plants that are a genus use there family as a parent.

Family parents and the loading of categories higher than family are not loaded.
There should be a script that loads these checked into cvs.

Ideally an ant task should be designated for this step ( or at should be
documented in the "/vegbank/veg_taxa/README" file.

#7 Updated by Michael Lee over 17 years ago

changed from components that are to be deleted to "misc" so that bugs don't get
deleted with component. Sorry for all the email.

#8 Updated by Redmine Admin over 9 years ago

Original Bugzilla ID was 703

Also available in: Atom PDF