Project

General

Profile

Actions

Bug #739

closed

QA for New XML (1.0.2) loading (Lee), then Fix errors in loading process (Farrell/Anderson)

Added by Michael Lee over 21 years ago. Updated about 19 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
misc
Target version:
Start date:
11/13/2002
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
739

Description

JH fixes


Related issues

Is duplicate of VegBank - Bug #743: [520] Data loader plugins:XML plots:Values for required fields missingResolvedMichael Lee11/13/2002

Actions
Blocks VegBank - Bug #740: New XML -- DESIGNResolvedMichael Lee11/13/2002

Actions
Blocks VegBank - Bug #870: New XML export and import into the VegBank systemResolvedGabriel Farrell11/13/2002

Actions
Actions #1

Updated by John Harris about 21 years ago

This is a duplicate of a bug that was fixed by Gabe in early Jan. 2002.

Actions #2

Updated by Michael Lee about 21 years ago

This bug actually deals with the implementation of the new XML that has yet to
be designed.

This bug should be marked resolved when the new XML is implemented and working
with the VegBank system.

Sorry for the lack of clarity.

Actions #3

Updated by Michael Lee over 20 years ago

First, Michael should QA/QC the new XML loading into VegBank. Any errors
should be reported and this bug passed back to Gabe or Mark so that these
errors can be fixed.

Actions #4

Updated by Michael Lee over 20 years ago

find XML to test this here:
http://vegbank.nceas.ucsb.edu/xml/

http://vegbank.nceas.ucsb.edu/xml/vegbank-data-example-verbeta1-1.xml
is should conform to Gabe's initial design of the loader

http://vegbank.nceas.ucsb.edu/xml/vegbank_example_ver1.0.1.xml
is a simple example for the current 1.0.1 schema.

Actions #5

Updated by Michael Lee over 20 years ago

Almost no errors! REally great loader. Need to test most diverse plots, still.
First analysis:
missing in export:
project start date [in db]
3 stratumTypes::children of stratumMethod
party/address not in xml
taxonObs/reference.pubdate not in xml
<plantConcept.accessionCode>VB.92435</plantConcept.accessionCode>: not correct.
This was loaded in Vegtest- no accession code should be
made. Furthermore, this is not the right style for a plantCocnept acc code :
VB.PC.162.ACRU is right.

Actions #6

Updated by Gabriel Farrell over 20 years ago

Some aspects of #5 addressed ...

Dates now work,
Children of Stratumeethod exported ( and coverMethod )
Format of PlantConcept and Commconcept accessionCode now correct

Also, if loading to vegtest no accessionCodes loaded, see my e-mail about this
however, as this results in other things being broken and I think there is a
better way.

Actions #7

Updated by Michael Lee over 20 years ago

need to do this again for new XML

Actions #8

Updated by Michael Lee over 20 years ago

  • Bug 743 has been marked as a duplicate of this bug. ***
Actions #9

Updated by Michael Lee about 20 years ago

First run at QA on the new XML import has been completed:
--all entities were imported into the database correctly, with 2 minor bugs--

bug 1) duplications : we have duplications of stratum records, stratumType,
aux_role, etc. being added. These were avoided previously by logic that checked
for an extant record in vegbank that matched all attributes. This is not
something that we can presume, though. So, this logic removed, but the
duplications are now being added. So, a hash table or something needs to keep
track of which XML elements have already been added (using table & PK) and what
VegBank element they correspond to (PK).

bug 2) taxonInterpretation.plantNAME_ID not being populated. This field, alone
as far as I could tell, contained data in the XML upload, but was not filled in
during the import. I cannot say why that is.

Actions #10

Updated by Michael Lee almost 20 years ago

Short run through of example data XML sets have worked perfectly. Should do a
detailed "every field" test, as well.

Actions #11

Updated by Michael Lee about 19 years ago

successful QA completed, focusing on FK's for each observation, compiling the
total number of related entities and comparing for source (vegbranch) and
destination (vegbank). Matches were 100% correct, except for classContribs,
which might not have been written into XML. Checking on that last aspect.

Actions #12

Updated by Michael Lee about 19 years ago

changed from components that are to be deleted to "misc" so that bugs don't get
deleted with component. Sorry for all the email.

Actions #13

Updated by Redmine Admin almost 11 years ago

Original Bugzilla ID was 739

Actions

Also available in: Atom PDF