Project

General

Profile

Bug #1188

add 'formatted printed output' for datapackage metadata

Added by Dan Higgins over 16 years ago. Updated about 16 years ago.

Status:
Resolved
Priority:
Normal
Category:
morpho - general
Target version:
Start date:
10/16/2003
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
1188

Description

Comment from Sandy Andelman -
Formatting metadata output for printing. Again, based on our experience, most
ecologists want to be able to print out the metadata they have entered in an
easily readable format. I don't think it is sufficient to be able to view it on
the screen. Right now one can print out metadata, but not in a format that is
useful.

printedOutputExample.html (29.6 KB) printedOutputExample.html Dan Higgins, 10/16/2003 01:27 PM
knb.css (5.56 KB) knb.css Dan Higgins, 10/16/2003 01:32 PM

Related issues

Is duplicate of Morpho - Bug #1215: Adding a Print menu option in MorphoResolved11/20/2003

History

#3 Updated by Dan Higgins over 16 years ago

Creating an html output file is easy. Basically this is the same as our current
export function with an eml2 transformation. Actually PRINTING the html is a bit
more complicated. Can we use a browser? (or do we want Morpho itself to do the
printing?)

#4 Updated by Matt Jones over 16 years ago

We want Morpho itself to do the printing. This may not be feasible under our
time constraints, but it would be nice if we could swing it (as its one of
Sandy's big 3). At a minimum we need the export file to be nicely printable in
the beta1 release. Maybe a beta2 release could add the printing support. I
looked into printing in Java, and it doesn't look too had if you already have it
rendering in a Graphics (or Graphics 2D) context. As Matthew's metaviewer code
already does this (XML->HTML->Canvas), maybe some part of it could be modified
to provide the printable canvas? I got my printing info from:
http://java.sun.com/docs/books/tutorial/2d/printing/index.html
and
http://java.sun.com/printing/whitepaper.html

#5 Updated by Matt Jones about 16 years ago

  • Bug 1215 has been marked as a duplicate of this bug. ***

#6 Updated by Perumal Sambasivam about 16 years ago

Printing feature added to Morpho.

#7 Updated by Redmine Admin almost 7 years ago

Original Bugzilla ID was 1188

Also available in: Atom PDF