Project

General

Profile

Actions

Bug #1286

closed

A top-level 'Home' window that does not go away until user closes Morpho down....

Added by Rick Reeves about 19 years ago. Updated almost 19 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
morpho - general
Target version:
Start date:
01/23/2004
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
1286

Description

In short, have Morpho follow the 'Multiple Document Interface' (Thanks for the
metaphor, Mr. Higgins!), in which successive Datapackages inhabit separate,
closable 'documents' that are children of a parent 'master control window'.
Users have become accustomed to having this conceptual 'anchor' when using
a GUI-based software package.....


Related issues

Is duplicate of Morpho - Bug #1280: Return to the ‘Main Morpho (blue) Screen’ResolvedSaurabh Garg01/23/2004

Actions
Actions #1

Updated by Saurabh Garg almost 19 years ago

  • Bug 1280 has been marked as a duplicate of this bug. ***
Actions #2

Updated by Saurabh Garg almost 19 years ago

Comments for Bug 1280:

Reported in morpho-feedback-20040122.doc in /doc/devs/ by Andrea Chadden
After finishing the last screen of the Datapackage Wizard, the user should be
returned to the ‘Main Morpho (blue) Screen’, which appears to be the central
control screen for Morpho activities, or at least see some button on the new
Datapackage screen that leads the user back there

Actions #3

Updated by Dan Higgins almost 19 years ago

Code has been changed so that the intial blue startup screen does NOT disappear
when another frame is created. Now the startup screen remains until closed by
the user.

This is not a Multiple Document Interface is the usual sense, but still gives
the user access to the intial screen.

Actions #4

Updated by Dan Higgins almost 19 years ago

Initial Morpho screen not closed as it was before.

Actions #5

Updated by Redmine Admin almost 10 years ago

Original Bugzilla ID was 1286

Actions

Also available in: Atom PDF