Project

General

Profile

Bug #1293

Browsing Data Package Wizard with minimal use of mouse

Added by Saurabh Garg over 18 years ago. Updated over 18 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
morpho - general
Target version:
Start date:
01/30/2004
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
1293

Description

Following suggestions need to be taken care of:

-> Ctrl keys for going forward and back.

-> focus should be on Next button for screens with not required fields and on
the main widget in screen with required fields.

-> In keywords, new entry should be made possible by pressing enter ...

-> In custom list, by default add action should be possible by setting a flag.
Hence some screens may use this functionality - some might not.


Related issues

Is duplicate of Morpho - Bug #251: add return and escape defaults on wizardResolved07/12/2001

History

#1 Updated by Saurabh Garg over 18 years ago

  • Bug 251 has been marked as a duplicate of this bug. ***

#2 Updated by Saurabh Garg over 18 years ago

From bug# 251:

The "New Data Package" wizard requires mouse clicks to move from screen to
screen. Need to add the "Retirn" key as a default for the "Next" button, and
the escape key as a default for cancel. "Alt-N" and "Alt-P" for next and
previous would also be nice.

------- Additional Comment #1 From Matt Jones 2001-07-12 17:11 -------

Changed milestone for a number of morpho features that will not be able to be
completed by Beta 1 (ESA). Delaying these features to Beta 2.

#3 Updated by Saurabh Garg over 18 years ago

All the features entered, except for
"In keywords, new entry should be made possible by pressing enter ..."

That has been added to 1381

#4 Updated by Redmine Admin over 9 years ago

Original Bugzilla ID was 1293

Also available in: Atom PDF