Project

General

Profile

Bug #1344

Cancel button on delete screen leads to a blank screen

Added by Saurabh Garg about 16 years ago. Updated about 15 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
registry
Target version:
Start date:
02/11/2004
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
1344

History

#1 Updated by Matt Jones over 15 years ago

The cancel button on delete still leads to blank, but also after successful
delete the screen is blank. Retargeting this at 1.5.

#2 Updated by Saurabh Garg over 15 years ago

Not able to reproduce the blank screen after successful delete. I get a Success
message.

#3 Updated by Veronique Connolly over 15 years ago

I tried it with two different data packages and I got a Success message.

#4 Updated by Saurabh Garg over 15 years ago

Fixed. Not closing the bug right now as other changes in registry will also be
made, so will close this after testing of registry.

#5 Updated by Saurabh Garg over 15 years ago

Was able to reproduce the behaviour which Matt reported. This happens in cases
where there is a special character in the document. This is true for both edit
and delete functions.

For both edit and delete function, the document is retrieved from metacat and
parsed using XML::Lib->XML. Thats where the error occurs - the script exits
without doing anything and hence giving a blank screen. LibXML is not able to
read special characters.

Solution is to normalize before editing and deleting.

#6 Updated by Saurabh Garg about 15 years ago

Fixed by normalizing delete function.

#7 Updated by Saurabh Garg about 15 years ago

And closed.

#8 Updated by Redmine Admin about 7 years ago

Original Bugzilla ID was 1344

Also available in: Atom PDF