Project

General

Profile

Bug #1386

Error when local and network save done for a docid that already exsisting

Added by Saurabh Garg over 18 years ago. Updated almost 12 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
morpho - general
Target version:
Start date:
03/24/2004
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
1386

Description

To reproduce the bug - create a new document with docid same as docid which
already exsists in your directory. I am not sure how it gets the same docid -
but it has happened 3-4 times for me. So if I have a document with docid
sid.9.1 in data directory and morpho creates a new document with same docid.

-> So the first problem is that while generating the new docid - it doesnt
check with metacat server what was the last number used for creating a
document. I am not sure if it is supposed to do that because what will happen
when somebody is creating datapackages offline.

-> Second problem is the following - now somehow I have created a document with
same docid as a document that already exsists BOTH in data directory and
metacat server. I do a local and netword save. It does the local save - where
it removes the document which exsisted earlier. So I have erased an earlier
exsisting document. Secondly, it doesn't do the network save. I tried to open
the same document over the network - I got the previously saved document. Also
it never asked me to log in. So I am not sure if it even tries to do a network
save.

History

#1 Updated by ben leinfelder almost 12 years ago

There have been substantial enhancements to docid conflict resolution since this bug was entered. The methods for getting the lastDocId from local and network are quite robust these days - in fact I've never gotten a duplicate when working locally. When saving to local and/or network, conflicts must be resolved either by incrementing the revision or my generating a new docid. This functionality is working very well in the 1.8x era of Morpho.

#2 Updated by Redmine Admin over 9 years ago

Original Bugzilla ID was 1386

Also available in: Atom PDF