Project

General

Profile

Bug #1572

Error in uploading raw data to metacat...

Added by Saurabh Garg almost 15 years ago. Updated almost 15 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
morpho - general
Target version:
Start date:
05/18/2004
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
1572

Description

Following error was reported by Johnoel Ancheta <>

i am having some problems uploading to our metacat
server using morpho-1.5.1. it seems i can upload the
metadata but not the raw data. the error log is below.

docid in parseIdFromMessage: user1.54.1
MetacatDataStore: getting file from Metacat
Sending data to: https://localhost:8443/tao/servlet/metacat
HTTP Handler class is: sun.net.www.protocol.https.HttpsURLConnectionImpl
Name: docid => user1.54.1
Name: action => read
Name: qformat => xml
MetacatDataStore: getting file from Metacat
Sending data to: https://localhost:8443/tao/servlet/metacat
HTTP Handler class is: sun.net.www.protocol.https.HttpsURLConnectionImpl
Name: docid => WC97_241.2.1
Name: action => read
Name: qformat => xml
opening WC97_241/2.1 from temp dir - temp:
/home/tombo/johnoel/.morpho/profiles/user1/temp
id:WC97_241.2.1 filelength:4266572
Sending data to: |https://localhost:8443/tao/servlet/metacat|
Sending data file:
/home/tombo/johnoel/.morpho/profiles/user1/data/WC97_241/2.1
HTTP Handler class is: sun.net.www.protocol.https.HttpsURLConnectionImpl
HTTP Handler class is: sun.net.www.protocol.https.HttpsURLConnectionImpl
HTTP Handler class is: sun.net.www.protocol.https.HttpsURLConnectionImpl
Fatal error sending binary data to Metacat: Illegal character(s) in
message header value: multipart/form-data;
boundary=--------ieoau._._+2_8_8.3-dskdfJwSJKl234324jfLdsjfdAuaoei-----^M

java.lang.Exception: Illegal character(s) in message header value:
multipart/form-data;
boundary=--------ieoau._._+2_8_8.3-dskdfJwSJKl234324jfLdsjfdAuaoei-----^M

at edu.ucsb.nceas.morpho.Morpho.sendDataFile(Morpho.java:743)
at
edu.ucsb.nceas.morpho.datastore.MetacatDataStore.newDataFile
(MetacatDataStore.java:610)
at
edu.ucsb.nceas.morpho.datapackage.AbstractDataPackage.handleMetacat
(AbstractDataPackage.java:2734)
at
edu.ucsb.nceas.morpho.datapackage.AbstractDataPackage.serializeData
(AbstractDataPackage.java:2623)
at
edu.ucsb.nceas.morpho.datapackage.EML200DataPackage.upload
(EML200DataPackage.java:267)
at
edu.ucsb.nceas.morpho.datapackage.DataPackagePlugin.upload
(DataPackagePlugin.java:974)
at
edu.ucsb.nceas.morpho.query.LocalToNetworkCommand$1.construct
(LocalToNetworkCommand.java:226)
at
edu.ucsb.nceas.morpho.framework.SwingWorker$2.run(SwingWorker.java:140)
at java.lang.Thread.run(Thread.java:534)
id:user1.55.1 filelength:4266572

Related issues

Has duplicate Morpho - Bug #1570: Error in uploading raw data to metacat...Resolved05/18/2004

History

#1 Updated by Saurabh Garg almost 15 years ago

duplicate of bug # 1570

  • This bug has been marked as a duplicate of 1570 ***

#2 Updated by Redmine Admin about 6 years ago

Original Bugzilla ID was 1572

Also available in: Atom PDF